One possible simple repair for My Books not powering on


#1

My out-of-warranty WD My Book Essential II USB 2.0 drive (MDL: WD5000H1U-00) stopped powering on recently, and after testing the wall wart output and trying a different USB cable & computer, I opened the enclosure and tried the bare drive in another enclosure, and it works fine.

So I started testing the I/O / power supply PCB (I am an electrical engineer).  Mine says FIREFLY 1U/1B in the upper right on the component side.  With the 12V power attached, there was no voltage appearing across the 1000uF cap (C55), so I assumed the 12V to 5V DC-DC (switching) converter circuit was not working.  Nothing looks scorched, swollen, or out of the ordinary physically.  Then I happened to test the voltage at the output of the inductor (L19) and I was getting 4.X volts!  I looked more carefully, and apparently the surface-mount inductor solder joint had opened!  If the inductor is not connected at one end to the output capacitor, things aren’t going to work!!  So I resoldered it down, and voila, it worked perfectly again.

I think this could be the source of many complaints people have about WD My Book drives failing in high-use applications.  The more time the drive is powered on, the more vibration the surface-mount inductor will experience (mostly from the drive mechanism but also from its self-induced switching vibration), and the more likely the solder joint will fail.  If you know your bare drive is good, look carefully at the FIREFLY 1U/1B board and test for continuity between both ends of the inductor and the + terminal of the 1000uF output cap (C55)!  Or, better yet, check for continuity between pin 8 (SW) of U4 (the NX2114 controller chip) and the + terminal of the output cap.  I hope this saves somebody from losing data or throwing away a perfectly good hard drive!