One PC cannot access My Cloud on network any longer...other PC's can

I have a MyCloud on my home network. Have been using for years. About a month ago it seems I lost access, as it was no longer saving recorded media assigned to it. It no longer shows up in File Explorer on one PC. Works fine on two other PC’s in the network. Using Windows 10 Home.

I have checked the following, but nothing changed:

  • Turned SMB in Windows Setting On and Off.
  • Network Discovery is ON.
  • Network is Private. Private File Sharing is ON.
  • I can ping MyCloud
  • nbtstat shows device in table
  • nslookup shows same DNS IP as other PC’s
  • Tried to update adapter driver. It is up to date.
  • Using Cat6 connection. Switched to Wifi. No change.
  • Device does not show up in Explorer (under Computers). Another NAS does, but will not connect either.
  • Does show up under “Storage”. Opens from there in browser (http)
  • Attempting connection by \name or IP does not connect.
  • Manually added login in Windows Credentials. No change.
  • Problem PC appears to have all Win 10 updates as other working PC’s.
  • Even did a reset on the problem PC. Nothing changed. Still will not connect.

I’m stumped. What am I missing? Why only one PC cannot connect?

I think I may have found the problem. The MyCloud is acting as the Master Browser. If this is the issue, how do I make my main PC the Master?

Is the problem PC a desktop or laptop computer? Is it in the same work group?

It is an HP desktop. It belongs to “workgroup”. Is there more than one? I turned off the MyCloud for a moment and the master browser (MB) kicked back to the dekstop. Still no access to MyCloud, but it did make it show up in list of devices again.

Some people seem to indicate that the Windows Updates cause this issue. But all my PC’s are up to date (same state).

If one turns off the SMB1.0/CIFS option in Windows 10 they will have trouble accessing the My Cloud using it’s name and will have trouble seeing the My Cloud in Windows File Explorer. Make sure that this option is enabled/on as sometimes Windows updates can turn off previously enabled options/settings.

If Master Browser is really an issue there is some discussion on disabling this option on the My Cloud using SSH both in the following thread discussion (Windows 10 Specific Method 6 - Third option) and elsewhere (use the forum search feature, magnifying glass icon upper right).