One or more RAID volumes are degraded on brand new PR2100

Hi, my brand new 28TB PR2100 NAS was delivered by courier a couple of days ago.
I plugged it all in and initially had some difficulty talking to it consistently, the login process kept timing out. I think this was due to a slightly poor Ethernet connection. But that is now fixed and I have an admin account set-up.
As I am a WD NAS newbie, I checked through the menus and under Storage > RAID> RAID Profile saw Raid Health = Degraded.
But under Storage > Disk Status it says Disk Health = Healthy. Very confusing.
So I pressed the Manual Rebuild button. This seemed to sort it out.
I also discovered that there was new firmware available and an update from OS3 to OS5. These were duly downloaded and installed. But then I saw that the RAID Health = Degraded status has re-appeared.
Under OS5 RAID Profile there is an Auto-Rebuild On/Off selector, set to ON, but no Manual rebuild button. I tried clicking on the On part of the selector and I think I got a message saying something like “Rebuild in progress”. This disappeared but the Degraded status is still present.
Under Settings > Utilities > System Diagnostics there is a Quick Check function. I ran that it and it reported good health (I can’t recall the exact wording). I’ve also run Scan Disk on both drives and they report Healthy. I believe I’ve run the RAID rebuild function several times now but the RAID Health = Degraded status is still there.
Somewhere along the way I saw a Red status light underneath Drive 1 but that cleared.
So yesterday I set the Full System Diagnostic running. It is still running after about 18 hours. Judging by the progress bar ‘lack of’ progress, its got about another 6 hours to run.
So obvious questions

  1. How have I messed this up?
  2. What can I do to fix the RAID Health = Degraded status
    Thanks in anticipation :slight_smile:

Haven’t got as far as putting any data on yet!
Our macs have both Time Machine and CCC local backup drives. The PR2100 is intended to be a 3rd, ‘nearly’ offsite backup while we wait interminably for proper fibre to the premises broadband. Then we can have real offsite cloud backup.

You have a new system and it is not a good idea to take too many steps forward ie new firmware before fixing any original start up problems.

YES as he said reformat and test each disk

and make sure indexing is off for OS5 as you continue setting up.

I connect each new disk to my PC before using on a NAS and test with WD diagnostic programs.

you never know now many times a disk may have been dropped in shipping.

(in the OLD day a disk came with a g-meter shock tape device)

Ok, update.
The System Diagnostic Full Test has completed and reports no problems.
I ran Scan Disk on Volume_1, result “No error found” but Raid Health = Degraded still.
Clicked on the re-build control several times. Still broken.
Found and checked System Logs. Seems the default sorting is by severity and then time. So right at the bottom of the log-file I see an Info log “A new drive has been inserted into Bay 1. To add this drive to your system’s RAID …”
Hover the cursor over the entry and it gets expanded to “A new drive has been inserted into Bay 1. To add this drive to your system’s RAID set, navigate to Storage >> RAID and click the Change RAID Mode button.”

This starts to remind me of a quote from the Hitch Hikers Guide to the Galaxy where the rather important piece of information about the demolition of the Earth is on ‘public display’
“But the plans were on display…”
“On display? I eventually had to go down to the cellar to find them.”
“That’s the display department.”
“With a flashlight.”
“Ah, well, the lights had probably gone.”
“So had the stairs.”
“But look, you found the notice, didn’t you?”
“Yes,” said Arthur, “yes I did. It was on display in the bottom of a locked filing cabinet stuck in a disused lavatory with a sign on the door saying ‘Beware of the Leopard.”

So off we go to Configure RAID Mode. The only option is JBOB (kudos dswv42 :slight_smile: )
Click on that and it runs a disk check on Drive2, result ‘Good’
Next step “This section allows you to choose which volumes you want to encrypt.” Offers me Volume_1 but I leave it at Unlocked
Next section “This section provides a summary of the configuration you just created. It will show the volume name, disk size and disk array number.” It only mentions Drive2.
So I click next… "Be patient while … " then “The data volume of your My Cloud PR2100 is being formatted. Please wait.” …
Finally it completes.
So now I check Disk Status. “Disk Health = Healthy”. But for System Disks we have the dreaded “Please wait” …
So I’m going to bed and will update further in the morning.

Waking up this morning, there is a red light under one of the drives and status is JBOD 13.88TB i.e. one 14TB disk short.
Powered it down and moved it into my office so I could see better what is going on.
Powered it up and it says “Insert Hard Drive” yet there are definitely 2 inserted.

Conclusion - this device is ‘Dead On Arrival’, presumably damaged in transit.
I’ve raised a support request.

you might try swapping the disks or try another disk before doing a return if you are expecting a long return process.

yes. . . try that . . .and also try reinserting.

But returning to where you bought it is a very, very likely outcome. You should not put up with problems like this out the gate.

Got no response to my online support request so tried phoning up the Western Digital online store support as that is where I bought it from. Got through quite quickly. Carried out a few tests with the agent and he agreed that Drive 1 was faulty. RMA being raised.