Odd problem with access shared folders *sigh*


#1

Hi Guys,

First post, so be gentle.

I have just opened my new WD TV Live device, and installed it all.

I have it plugged in via ethernet to my home network, and have assigned it (through DHCP reservations) an IP Address. The device successfully talks to “The Internet”.  I know this because the first time i turned it on, it downloaded three seperate instances of Firmware Updates (now running version 1.04.17_V).

I run a Domain in my house, consisting of one Windows 2003 AD Controller, Four workstation PC’s running a variety of Windows XP and Windows 7 Ultimate X64. I also have a few other bits and pieces (TV etc), not relevant to this thread). Devices relevant are as follows:

MORPHEUS (Win2003 AD Controller)

TRINITY (Windows XP Client)

NEO (Windows 7 Ultimate X64 Client)

WDTVLIVE (WD HD Live device)

MEDIAPC (Windows 7 Ultimate X64 Client) <- This is effectively just a machine with a chunk of HDD Space acting as a file sharing device. It also runs WMP as a streming media player for my DLNA enabled TV (which i dont actually use).

These devices (with the exception of the WD TV device) are members of the same domain. Given that the WD TV device doesnt have the ability to join a domain, the workgroup in the WD TV has been set to the same netbios name as the Domain. Authentication and shared folder access works perfectly fine across the domain.

I had a few Master Browser teething issues to start with, which I have now sorted out.

Here is where things get a little odd. I can access the various shared folders from the WD TV Device on all but on of my networked PC’s. Authentication works fine on the NEO, MORPHEUS and TRINITY machines, but NOT the MEDIAPC machine (wouldnt you believe it!).

The authentication itself seems to be behaving a little strangely. Normally to access shares from a non-domain machine, you would need to structure the crentials in the form of “domain/username” and the relevant password for the domain user. The WD TV Live device doesnt seem to behave in the same fashion.

The ONLY way i can access shared folders on the abovementioned machines is by using the domain username of the user logged into the machine! (odd i know).

For example, on the TRINITY machine, the user logged in might be “john”. Through the File Management of the WD TV device, if i enter “john” and the corresponding password, it works fine. If i use the domain\username standard, it does not work. This example is true (as mentioned) for the NEO, TRINITY and MORPHEUS machines, but it does NOT work for the MEDIAPC machine.

I hope im making sense up to this point.

I have reconfirmed and reconfigured my settings on my shared folders to be the same across all machines on my network (IE: NTFS = everyone, full control, and the same with Sharing). So the settings I have on the machines that work, have been replicated to the one that doesnt work.

So, my questions are:

  1. Does anyone have any tips i might benefit from when it comes to user authentication from the WD TV Live device, when running over a domain? Even though it kinda seems to work, it seems a little outside the norm for non domain member authentication (which is cool - i know the device isnt designed to behave like this, just looking for tips)

  2. Does anyone have any idea why the authentication method im using for all my other PC’s might not be working for  my MEDIAPC?. I am attempting to use the “Administrator” credentials (which work with the AD Controller).  I have also searched high and low for any trace of windows live / Windows live essentials etc, but cant find any trace of it whatsoever. I havent tried any guest / anonymous access yet. Im sure i should be able to get it working the same way that the others work. I have also tried the credentials that work on the other machines, on my MEDIAPC…to no avail.

I should also mention that it all works fine when streaming media from the MEDIAPC. No problems there.

Thanks so much for any help anyone can provide. This is quite frustrating!.

Dave


#2

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en