Not transferring photos accurately

I wish to copy photos from a notebook to my desktop. I realize I should set up a network in our home to accomplish this, but for now, I am just trying to copy vacation photos onto an external WD hard drive in order to move them to my desktop.

When the copy is done, I checked that the photos look fine on the external HD, but they don’t. I have done this with two of my My Passports - a 1TB and a 2TB, and both give me similar corrupted photos.

I am not sure what system info is required, but my notebook is Windows 10, and the EHD’s are about 3 years old. Any advice?


This is strange. What happens if you open the photos? do they look fine or they still look like the thumbnails Preview?

Also, have you tried to copy them to a different drive? if yes, do you get the same result?

I get the same corruption on two different WD external hard drives. Neither the thumbnail nor the actual photo are readable. I am in the process of slow reformatting one of those HD’s. It takes a long time, and has been reformatting for almost 24 hours now.
I also wonder if it is possibility that a USB port is faulty

I have reformatted the WD drive, and tried again on a different USB port. The files are still fine on the Notebook, but corrupt on the WD drive.

I will reformat the WD drive again, and copy some photos on my desktop to the WD drive. If that works, then I presume my problem is not the WD drive, but the actual Notebook laptop.

Looks like you’re losing data in the transfer or the headers on the jpegs are getting corrupted. I suspect a problem with the WD drive if it uses encryption. It’s not encrypting/decrypting correctly if your drive has that feature.

You could try archiving the photos in a rar file, using winrar or the free 7-zip. Then download the free Quickpar for Windows and create a generous series of par files from the rar file.

Transfer both the rar files and the pars to the external drive and use quickpar to reconstruct the rar file if required. You might observe whether the rars and pars transfer correctly. Note the sizes before and after transfer. Same with the photos.

Alternately, try transferring different kinds of files to see if they work right on the EHD. If they don’t you have a problem. Try another EHD if you can to see if the same problem exists.

You can eliminate USB errors by plugging a thumb drive into a USB port to see if the transfers happen OK.

Quickpar is an amazing app that somehow translates the data bits in a file to par files so the original file can be reconstructed if it is damaged. It’s not worth making pars for 1 jpeg but you could rar a 100 or more then use the pars to repair the the rar.

Thanks for the reply Gord. I have not resolved the transfer-from-notebook-to-My-Passport issue, but I have solved my problem by purchasing a My Cloud NAS drive and attaching it to my home modem.

That was always my long range plan as it solves a number of issues in our house - this one included. Now the notebook storage is accessible from my desktop directly without using the My Passport. (I am also learning about auto-backup and using the My Cloud abilities to share photos with my kids, etc.)

At some point, I will spend more time trying to determine exactly why my notebook and EHDs don’t talk to each other, but it is a lower priority now that I actually have access to the notebook’s hard drive.

Thanks again