NOT SUPPORTED June 2023 Local drive mounting via WD Discovery for My Cloud Home desktop ends **with Tailscale Fix DIY

whelp, I took your advice, I just broke down and spent a grand on a synology and a 20TB drive, now I have to figure out what table legs to put the 3 MCH under.

you cannot as access to the account require authentication from WD server using the built in software but they have enabled SMB so you can connect it via windows network drive. The only inconvenient thing is it need a separate local login(different to the one you use online and for app) for each user, this can be setup by going the local IP of the MCH device. Also if you need to login to a different account on the same computer you need to disconnect the current map drive first via command prompt using the “net use * /delete” as there isnt an option on the dropdown.

1 Like

They advertised this device wrong… its not a NAS drive… it should be call a NCS - Network cloud Storage


No. WDC knew exactly what they were doing. This is a light duty HOME storage device, not a traditional NAS with all its features. Those who wished to run businesses and heavy duty media serving from the MCH were disappointed in the end because the MCH usually did not last much longer than the 2 year warranty under heavy use, at least using the old firmware. The new firmware removed the old Android OS and its hybrid file system and now allows the HDD to spin down when not in use.

My Cloud™ Home is an easy-to-use personal cloud storage device

A few questions on this imminent change using a Mac and Local Network Access:

  1. Will desktop sync still work? Currently, with WD Discovery, certain folders can be synced with the Mac (a green checkmark is added next to the synced folders/filenames).

  2. With WD Discovery, even when outside the local network, changes to the desktop synced folders would be reflected on the MCH. Will this still happen without the WD Discovery?

  3. When enabling Local Network Access, does the local user name need to be something specific/linked to the overall setup of the MCH, or can this name be anything not previously used?

Thank you for clarifying (I could not find answers to the above in the help files provided on the WD help files).

1 Like

These are not imminent changes as I read it (WD link first post). WDC is just posting that they no longer wish to expend resources in updating WD Discovery to work with new versions of desktops, whether newer macOS or Windows after June 2023. So presumably if macOS stayed at Ventura and Windows at the current build of Windows 11, there will be no loss of functionality and WD Discovery desktop sync and remote sync should still work. If future OS file system changed, it will likely break WD Discovery as we have seen this frequently with macOS updates.

**** CORRECTION, on second read, it does look like desktop network support will stop in June 2023 which means even if WD Discovery is running, there will be no mounted REMOTE drive and it will not show on the desktop, however locally mounted MCH is unaffected.

As a desktop user of this WDD feature, your best bet in replacement may be to install Tailscale which is free for personal single user (log in) use, 20 device limit.

WDDiscovery desktop notification warning end of support and utility in June 2023

As to #3, once local access is enabled, the local user name and password can be anything that is acceptable to the OS SMB authentication and can be changed as often as necessary through the wed app or alternatively directly via ip address as shown here:

1 Like

Desktop sync is an essential element of MCH for me. MacOS will most most certainly be update like clockwork in Oct 2023. Considering that every macOS update has “broken” the existing WD Discovery, this will most likely happen again with the next macOS version. As such, WD Discovery’s like will end by October for users who update their computers in a timely fashion.

And this the question: what replaces desktop sync functionality which is a major part of MCH? I was told by a WD rep tonight that WD is “working” on something, but couldn’t confirm whether desktop sync works with Local Access Network …

Any ideas?

1 Like

Please read the original and the third post, this remote networking technology has existed for a few years now and it is free for personal use and it is called Tailscale. The post link below shows Tailscale in action in a mobile app, but it works as well or better with any desktop (Linux, macOS, Windows).

The WDC MCH development team could make this easier by supporting Tailscale natively as a Debian client but the mesh VPN network functionality already works right now with a Tailscale subnet router. Many Synology and other NAS already support Tailscale.

Copying entire folder remotely from Android phone to My Cloud Home private space (Public space and two way copying and sync also possible) with Tailscale and third party Android file manager, without the use of My Cloud Home mobile app. Tailscale supports Linux, macOS, Windows, iOS and Android.

There is now a suggestion thread on running Tailscale natively in the My Cloud Home over in the ‘ideas’ subforum. Please go over to that thread and voice your support if you think this is a useful feature.

However, you don’t have to wait for Western Digital, you can run a subnet router right now with only a few steps and you will be able to access your My Cloud Home remotely with third party software without the use of MCH specific software or WD relay servers **

Thanks to Posted by rednessw4rrior for the following:

Here is the how-to-configure TailScale Subnet Router for Windows Machine

The Windows installer places a tailscale.exe command in %PATH%. You set Windows up as a subnet router using a cmd.exe shell with the same command as Linux:

tailscale up --advertise-routes=…

So, if the home router IP Range is,

you’d likely want to use the following on CMD:

tailscale up --advertise-routes=

OPTIONALif you have another set of subnet, remember to add rightaway after the first one, otherwise you will have to reset everything and do it again but with all the subnet you want to add.

example of multiple subnets cmd : tailscale up --advertise-routes=,

then, go to Tailscale

click Edit Route Setting on that Windows Machine.Turn on the Subnet Route , all done!

that’s it! :slightly_smiling_face:

** Tailscale Subnet routing performs best with a Linux machine (physical or virtual router running Linux such as OpenWRT for example), but performance is acceptable with recent Tailscale development since version 1.26 and higher on Windows.

macOS client subnet routing

Download Go Installer for macOS.


$ go install{,d}@main

$ sudo $HOME/go/bin/tailscaled

$ sudo $HOME/go/bin/tailscale up --advertise-routes=192.168.x.x/24`


Wow that so much worst since yesterday 9.4 update !
Now the SMB file has completely disappeared from my local network.
I reboot MCH twice but local configuration page still saying “internal access error”

By the way, the update started automatically when backing up a 1TB directory and MCH rebooted, ended the transfert.
And I don’t know why, but after switching files on the device, I lost a lot a free space, while it should stay the same.

Bad day …

Log into My Cloud Home portal with your credential again (may have to do this twice if it errors out the first time) and it should show up.

My Cloud Home Firmware 9.4.0-191 Release Notes

Version: 9.4.0-191

Release Date: 01/31/2023

Supported Devices: My Cloud Home, My Cloud Home Duo, ibi

Updates In This Release

  • Resolved an issue where a few My Cloud Home users were unable to access files after enabling local network access
  • Resolved an issue where a few My Cloud Home users were unable to delete files after updating to 8.10.0 or above firmware
  • Optimized security posture and resolved an issue that could result in information disclosure or denial of service vulnerability
  • Visit Western Digital’s Product Security Portal to find more information about our security fixes
  • Other minor bug fixes and system improvements

Nope, I still have the same error …
Capture d’écran 2023-02-03 à 20.10.22

You didn’t indicate you were using the macOS until now. I think the WD MCH team has surrendered and given up on Apple’s non-standard SMB protocol. Apple doesn’t think they should support SMB for third party devices and not for their home users. If you look at Apple’s support site, SMB adjustments are qualified by something like this:

This article is intended for enterprise and education system administrators.

Try disabling these:

Thank you for your help, I will open a support ticket as well.
That strange because the SMB access worked fine (even if I had the problem of the rights on the files) before the 9.4.0-191 update. I follow your indication and disable SMB 1 but it’s the same. I’ve also check my local network and it’s ok.
The error is not on macOS side, I still have the error on MCH local network configuration.
I’ll try with a windows computer too.

That’s frustrating because I spend the day backing up MCH in order to recover read permissions…

After the last and the second last update my “My Cloud Home” is very slow, it goes 90 MB/s in 10s, then 0kB/s in 10s then 90 MB/s again and pending like that when transferring a file. Another in this community said his Plex server is doing like this. Hope for a new update soon! Anyone else have this problem?

This is how to share Tailscale for free without exposing it publicly or sharing credentials. Sharing is included in every plan, including Tailscale’s free Personal plan.

Sharing your nodes with other users

Sharing lets you give another Tailscale user access to a private device within your network, without exposing it publicly. This can be helpful for giving contractors private access to a secure server, or sharing a private Minecraft server with friends.

WD Discovery is (in my opinion) an essential element in use of my Mycloud. I’ve bought an external networkdrive two years ago, expecting that western digital wil support acces via windows explorer. So from june on, I cannot use the network drive no more properly. The explanation on the website for alternatief is (in my opinion) for network specialist en not for normal consumers.
I hope that the management of Western Digital wil return on her decision, otherwise I feel myself obliged to complain to my local consumer authorities.


Called earlier today and this is what I got.

This Youtube video on how to set up a Tailscale Subnet Router is as good as any. Do this after a Tailscale account has been setup (free for personal use) and Tailscale installed on the desktop.

I have nothing to do with Tailscale or the Youtuber in this video.

thank you