Not showing up on USB 3 port

I have been through the troubleshooter at the top of this board and it doesn’t help.  I have also been trawling google all day.

I bought a new motherboard and processor and I used the sysprep tool to migrate my windows installation to the new hardware.  Everything was working fine except my WD My Book Essentials 2TB USB3 drive.  It shows up fine on a USB2 port.  But when I put it in a USB3 port it shows up as Unknown Device.  I have the SES 64bit driver installed (I use windows 7 64) and I have the smartware software installed.  I tried various suggestions that google found for me but none worked.

I have since re-installed windows 7.  Re-installed the chipset drivers and the USB3 controller drivers.  Mostly got my pc set up as it should be and then installed the SES driver and the smartware.  I connected the drive and still it shows as Unknown Device, but it works perfectly fine on a USB2 port.

I have tested my cousins 32gb corsair voyager flash drive on the same USB3 port and it works fine.

Can anyone please help me?  I bought this drive because it was USB3, backing up 380GB of files on the USB2 port says 21 hours and goes around 3Mb/s whereas I was getting 40Mb/s before the upgrade.


For some reason it does not like the extension cable!?!  As soon as I connect it without the extension cable (which I bought from a reputable computer shop - CCL) it works fine.