Not mounting desktop/ Won't turn off. Procedure for disconnect and reconnect

I’m new to hard Drives and forums, so please forgive me, ahead of time. I welcome any advise/ direction for both.

I had a power outage; with my iMac and WD MyBook[Studio Edition 500GB] turned on. After the power came back; the icon still showed up on desktop okay. I eventually opened the HD folder to find 3 folders, I highlighted one of them named “Desktop”. I thought it shouldn’t be in there so I clicked on “Get info”… I think, that’s when something appeared that said: “something? was Read Only”…

Also, Finder became unresponsive, which left My Book stuck open. (Thought there was something wrong with my internal). I panicked and relaunched Finder. That’s when the hard drive icon disappeared. Then, I think I tried restarting the iMac via the button- to no avail.

So… No icon; the WD button doesn’t work for turning off. The light is on & not flashing. It doesn’t show in Disk Utility but it shows in System Profiler as: “Unknown device”. My questions: * What is the correct procedure for safely disconnecting and reconnecting the hard-drive after unsafe removal? In w hat order do I plug and unplug and FW & power cords?..  S hould I try to restart the computer first? I’ve had both computer and WD on for weeks until I know what to do.**

Also, If I get the hdd to mount; should I delete that “Desktop” folder?… so as not to confuse my computer with another “Desktop”?  I’ll bet I could have avoided this, if only I hadn’t panicked & had just waited longer for the spinning beach ball to go away. Computer could have just been slow…Thanks for any advice:)

Hi there, the best way to disconnect the drive is to shut down your computer, then take the interface cable (USB or FIrewire) out and then the power adapter.

In regards to that 'Desktop" folder I would first check if it has something that I might regret losing if I erase it…

1 Like

Hi… Thank you for your response.

So Power down Mac. Then 1st unplug the FireWire and 2nd the power. From the hard drive or the iMac? Then do I reconnect in the opposite order?

Iv’e read (googled) slightly differing comments that say: it matters what order they are reconnected (Also, to wait so many minutes; before pluging either the FireWire or Mac power back in; so as to reset something?). Of course; Western Digital site should have more accurate fixes. This is the order that one of the other sites says how to reconnect in…

…*[Power down Mac, unplug Mac power cord (from back), unplug HD power   from  the back, unplug FW data cord from Mac then… Reconnect power cords, turn on  Mac and plug data cord back into Mac?] …     

.… Is this right? I just don’t want to miss anything that might be important.

The “Desktop” folder is empty and was created just a few months ago. so, maybe I accidentally dragged it in there. Although, it seems I have already deleted another Desktop that I found in there within the past year. Iv’e assumed that there’s only supposed to be 2 main folders (not 3). I’ll delete it then. Thank you very much:).

The Mac OS has directories that are subject to damage just like Windows directories are. When you have a power outage or unplug the power from your devices without first unmounting them from the desktop, chances are you will have directory damage. 

Disk Utility usually is capable of repairing MINOR directory damage. It can not, however, repair extensive damage. You’ll need something like ALSoft’s DiskWarrior (available from www.alsoft.com and Amazon) if you want/need to repair extensive directory damage. 

As to the drive not showing up in Disk Utility; this is a problem. The firmware of the drive may have been damaged. What I would try first would be cycling the power to the drive on and off. You’ll want to unmount the drive from the desktop first (otherwise you’re going to create more directory damage). 

Steps: 

Unmount the drive

Turn off the power to the drive

Wait a couple of minutes then power the drive back on - it should mount on the desktop by itself. 

As to the “correct” method of connecting and discounting any external device: 

Back in the day when Mac’s had serial ports and hard drives were connected via SCSI the procedure was to turn everything off, connect everything, then power your external devices on, then turn on the computer. To disconnect, we had to do the reverse. This included a mouse and keyboard. Failure to do so could (didn’t always) damage the hardware of the device and/or the computer. 

Now days with USB, FireWire, and now ThunderBolt (just announced) the correct method isn’t nearly as complicated. For storage devices, select the icon of the drive on the desktop and either move it to the trash icon in the dock, or right-click and select "Eject ". Once the device is no longer on the desktop you can safely disconnect it and/or power it off. 

For mice and keyboards, simply unplug them. No need to power the computer off. 

1 Like

Thanks so much. I love hearing how these things work.

Since there’s no icon and it’s not in Disc Utility (disappeared when I re-launched Finder); I assume the computer has ejected the Drive?  Unfortunately; the computer got turned off, since my last post. . I had to turn off the HD by unplugging the power cord from the back; (since the button doesn’t work now). Then I pulled the FireWire from back of Mac… Hope I didn’t screw-up. So I have no choice now, but to start the process with everything turned off.


Questions

Now that the computer is off; should I turn on the computer “first” and then plug-in the Drive’s power cord?… ….And do I plug in the FireWire “after” I turn on the computer or before?      …Also, Is it safe to “cycle” it by plugging and unplugging the power cord from the back of the Hard Drive; (In case the button still won’t work)? Am I making it more complicated than it needs to be? I guess I need it spelled out for me to “get It”:slight_smile:  Sorry. 

Hopefully; the button will work and icon re-appear; after I turn it back on.  That way, I can “cycle” it exactly the way you are suggesting.** If the icon does not show up; what’s the next step?..so I don’t cause further damage. **   Then, i would need to find out how to tell if there is ‘directory damage’ .  I hope I don’t have to use that DiskWarrior. Wonder if I can charge my Utility company for any damages. Any help is appreciated. 

Connect the FireWire first, power on the HD, then turn on the computer. This is what I would do if I were having your difficulties. This order insures that the drive has power (and hopefully spinning), and is connected correctly before the computer checks the ports for connected devices. 

Knowing Western Digital drive enclosures it should power on by itself when you plug the power in. (As to turning it off with the button… Sometimes you have to hold the button until the enclosure powers down)

Depending on where the hard drive is, listen to see if you can hear the drive (drives if its a RAID) spinning up. You’ll also want to watch the front of the enclosure (what the drive(s) is in), to make sure that the light is functioning and showing activity. 

If you still can’t see the mechanism in Disk Utility, you’ll have to contact Western Digital for a RMA (Return Material Authorization). 

If you can see the mechanism in Disk Utility, try to repair it first. If you can’t repair it, then you may have to reformat (erase) the drive. This WILL delete ALL of the data on the drive. Hopefully you have a semi current backup, or you can reinstall what you’ll lose. 

As to causing further damage… Chances are you won’t. Or if you do, its not going to make much difference. The Mac OS is fairly robust about repairing minor directory damage on its own without using Disk Utility. If you hear a lot of activity from the drive when the Finder loads, leave things alone. It may be that the OS is doing what it can to repair/rebuild the directories on the drive. This doesn’t necessarily mean that everything will be all and good when its done. You may still have to reformat at the least, or replace the unit, assuming its still under warranty.  

1 Like

Whew!

I followed your suggestions and I’m relieved to say: the icon is back:), light is showing activity (sounds more like hum than 2 disks spinning… so probably not RAID); I see it in Disk Utility; I’ve ejected and restarted- no problem (probably should have waited until I tried the Repair).

Now i’m trying to figure out how to Verify and Repair. It shows 2 icons for the Western Digital…  I think I’ll click on the top one and wait, then click Repair; if it says to. Right? Should I make a separate post for the Repair part of it? I haven’t searched all the Mac Help or WD’s Forums yet… 

Next I’ll be trying to learn how to  back-up the WD back-up (containing 460 GB- for Time Machine) or my Mac. Confusing stuff…for me…   definitely for a different post. [Maybe for Apple].

Thank you Greyland for all of your help…  and extra explanations- very much appreciated!

Cheyenne