Not getting an IP address

Aside from the RSS issue (in another post), now the unit will not get an IP address from my router.  I had this issue before when I first received it but it worked itself out over time.  Now after updating to v1.06.04 it’s lack of functionality is getting worse.  Could this unit be a dud?

WDTV Live (Gen 3)

FW: 1.06.04

Network: wired

Did you try a reset after updating the firmware? If the issue is not fixed you may contact WD support for a replacement.


I did reset the unit and that solved the RSS issue ( link) but it really didn’t fix the DHCP client stubberness when pulling an address.  Power cycled my router and switch to no avail so I just left the WDTV unpluged for a day.  The time of being off seemed to help because I’m currently back in business.  

I’m finding that the WDTV is slow requesting an address.  Have to power it on and give it 5 minutes before attemping to access anything on local network or Internet. 

Thinking that I might RMA this unit.  I’m a first time WDTV user but long time Popcorn Hour A100 so I’m not new to these network media streaming devices.