Not able to get past login screen

Everything was working fine for a few months. I was accessing my cloud with my smart phone and my desktop. I accessed with my wife’s smart phone and now I can’t get logged in. When I run the dashboard and get to the login screen, I type my desktop PC’s Window’s login (which is how I set it up), it goes to the normal dashboard screen, but then instantly comes back to the login screen. If I type in the wrong password, I get the wrong password message on the login screen. When I type in the correct password I do not get a bad password message. BUT, I’m not getting the wrong password message on the login screen because I’m typing in the correct password. When I type in the password and hit the Login button, I see the regular screen with the tabs ‘Settings’ etc. It then goes back to the Login screen.

Thanks for any help.


I have exactly the same problem and have just posted on this, i hope one of us gets a good reply.

If I understand correctly the Dashboard is 'kicking you out". Do you encounter the same result with a different Internet browser or after holding the reset switch on the unit?


I just tried in IE (always use FireFox) and got same thing. When I click the Login button it goes into the dashboard but then comes right back to the login screen. I also tried the dashboard on my wife’s laptop/FireFox using my same login info and got the same results. I’m going to try and do a reset and see if that helps. I tried using the admin user with blank password? That gives me the invalid user or password message. I may have disabled the admin account and changed the password for security.

I’ve read in the manual and online that resetting doesn’t wipe the data, that the data remains intact?

Ok. Did the 4 second reset thing and that seems to have fixed it. The system rebooted, I had to set my user password again as my user password was removed, but all seems to be there and fine. I don’t know what happened but suspect it had something to do with the resent firmware update I did? That’s about when this started happening.

I had exactly the same issue a month ago. Was able to fix it by unplugging the device and plugging it back. Today experience the same problem again. 

EDIT: I’m assuming the problem may be caused by mediacrawler process. When dashboard is shown, it tries to request the status of the process and gets unauthorized error.

WD support, any ideas?

I resolved the issue by following the reset guidance.

Before I got the issue, I did attempt a windows update which had failed. I dont know if that caused the problem?

I also discovered that my router was assigning dynamic IP addresses, meaning my shortcuts and links to the dashboard did not work anymore. I found the new IP address it had assigned for Mycloud and I change the settings in my router to ensure it assigned this as a static one. This allowed me to find and access the dashboard but it kept kicking me out until I did the reset. I dont know if the IP issue also triggered the problem?

So far, so good for the reset remedy.