Non shared folders have disappeared

After years of operation my MyBook World has stopped seeing/ erased/ lost … etc all the data not in the shared folders. We didn’t do anything new. Just tried looking at pictures one day and the mapped drive to our pictures folder is gone. I had everything mirrored so I removed one of the drives to hopefully prevent further loss. Everything of value was on a mapped drive that I can’t seem to Re-map. HELP!

I used EaseUS and it recovered a bunch of unreadable image files.

Also tried a Linux reader with no luck.

Thanks for any help.


I would have to say I need additional information. Your post indicated you have or had a RAID 1 (Mirror) configuration. If so, is the information gone from both internal disk units?

The files appear to still be there since the recovery software was able to get them. What the recovery was able to get was only 50GB of files that say corrupt when we try to view them. It appears to be both drives. All I seem to have lost is the path to the folders I had set up.


What happens if you manually try to follow the path used by the recovery utilities by means of the Command Prompt or Terminal?