"No Writable WD SmartWare Partition Found"

I have been using this external hard drive for many months now but for some odd reason everytime I plug it into my computer it won’t read the external hard drive.

Any suggestions on how to get it working?


WS SmartWare can’t recognize the partition of drive.

Somehow the drive is re-formatted outside of supported partition (NTFS, FAT32 for Windows and HFS+J for Mac)

Did you switch between Windows to Mac or visa versa?

Just installed my new WD about 2 weeks ago, suddenly I can no longer access the drive. Essentially monitor shows my hard drive but the WD (1 gig) drive is gone… Is there a way to reinstall the thing or is it a gonner???

Is there a way to reinstall the thing or is it a gonner???

Do you mean WD SmartWare software or get drive back to use it as backup?

You can simple re-format using Disk Manager/Windows or Disk Utility/Mac to be used by computer and/or with WD SmartWare software.  Once drive format is recognized by the WD SmartWare you can use it for back up or storage.

I am assuming the drive is spinning (not physically broken state).

Well, it was spinning but now has stopped spinning.

A friend is having this same problem. It says something about the drive being locked or no writable space, and the drive isn’t locked. I think she has tried to access the drive on Windows and it’s worked. I can also look at what’s written on the drive, but I haven’t tried writing anything to it without the SmartWare software.

If the drive is formatted FAT32, shouldn’t I be able to access it with either Windows or Mac? Why would simply looking at the files with Windows make the drive unwritable by a Mac?

I was having this exact problem until just now. 

I read the help file which suggested that I reformat the drive. I opened the “computer management” and went to the “disk management” section. 

The drive was there, but had no drive letter and was not “active.” 

So, I assigned a drive letter and made the drive active and everything worked. 

I’m using Windows 7. 

How exactly did you assign a drive letter to reformat it?

I went to “computer management” then to disk management… there are two blank things thent the C drive then the D drive that says recovery next to it… I’m not sure what to do next.

Same Problem here. What I have found as a solution is to restart your computer while the drive is plugged in to the usb.  It then reads the drive properly and all data is there and usable.  Atleast that works for mine.  Pain in the butt. but it works for me.

I did switch from a PC to a MAC with my drive. Can it be reformatted back to work with PC? Or, have I lost all of my information?

I have the same problem but I do not want to lost my data, I have more than 1,3 TB of data. Exist any application, software or method to restore the lost partition?