"No Writable WD SmartWare Partition Found" -- unless I reboot my computer


(On a HP Pavilion dv7 notebook with Vista Family Premium 32-bit with Service Pack 2)

The WD Smartware icon in the notification zone flashes. When launched, WDSmartWare shows "“No Writable WD SmartWare Partition Found” (in truth, my version is in French, so it shows “Partition WD SmartWare inscriptible introuvable”).

This is a disk that I have been using for months without problem on this notebook. Then I switched to a PC, and when I came back to the notebook, that was the result. If I reboot my notebook, it will work fine. But when I put it to sleep, and then I wake it up, this problem arises. This makes the hard disk unusable to me, since I always put my notebook to sleep and wake it up. There is no way I can shut it down and reboot it everytime.

By reading the forums, I got the impression that there might be a format issue (though it wasn’t clear how such an issue would have appeared). I transferred all content on some other disk (4 hours), and reformatted the disk on the notebook. The same problem still arises.

I have also updated the software (now AND the firmware to the last versions, hoping it might solve the issue, but it didn’t.

I have seen other people reporting this problem, in particular:
This person, like me, can use the disk if they reboot their computer. As they say however, it is a pain in the butt.

Could someone shed any light on this?

Thank you.

Read my post here and follow the instructions to solve your problem.


Mabikay - SLK

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.

Unfortunately the suggestions in your other post didn’t help.

The first remedy (which applies to your two first scenarii) is not applicable since when I open the Drive Manager, the drive doesn’t appear at all. Actually one drive related to the disk does appear, but it is the one with the 700 Mo partition with the setup files etc. I don’t see any other drive on which I could activate the partition as you suggest.

The third scenario doesn’t apply since I use Windows Vista, not XP, and it only regards XP systems.

The WD icon in the notification zone flashes, as I have indicated. If I click on it, the popup window says something like: “Detecting drive…” (it actually speaks French and therefore says: “Détection du lecteur…”).

I might also say that I have two virtual drives (I use Virtual CloneDrive) with content (always the same) in them and an empty one. So globally, as reported by Drive manager I have:

Disk0 - my hard drive with two partitions

CD-ROM0 - physical CD/DVD drive

CD-ROM1 - virtual drive with fixed CD image

CD-ROM2 - virtual drive with fixed CD image

CD-ROM3 - virtual drive, empty

CD-ROM5 - WD SmartWare (with the partition with the setup files etc.)

There is not CD-ROM4 for some reason… I don’t know if that helps.

I have just tried deactivating the virtual drives completely. I put the notebook to sleep, then back on. The partition with the setup files etc. is mounted, and the actual empty disk is still absent, so nothing is changed.

You said you were using on HP notebook Vista then a PC. What OS was the PC? I suspect drive corruption. It seems more common when sharing an externat between XP and Vista and later versions of Windows. Sharing between mutiple computers is a problem too. See if partition recovery will help I see this recommended Easuse Partition Manager http://www.partition-tool.com/


The other PC uses Windows 7.

Drive corruption cannot be the reason, because to rule this out I have reformatted the drive on the HP notebook, and then the problem reoccurred immediately, without even using it once on another computer.

Okay, I got the picture. You experience this problem after resume from sleep/standby. This may be your notebook USB hardware related issue and it is always advisable to update your BIOS and Chipset software. When Windows is waking up from low power state, it needs to re-enumerate USB devices as well other devices on your notebook.

As I said on first scenario, inherited laziness of My Passport might be failing to respond in time, within the given time slot.

As a workaround, you can try this. Reboot your Notebook as you normally do while your subjected drive attached. (There shouldn’t be any other USB drive attached at this time). Follow the instruction on my post and assign a drive letter as W or so. This will alleviate possible drive letter conflict.

Now open device manager and expand Universal Serial Bus Controllers. Look on the bottom of the list; you’ll find USB Root Hubs. Double click each USB Root Hubs and look in the power tab for your Ext Drive listed as USB Mass Storage Device. Power requirement should show as 500mA. Now click Power Management dab and uncheck “Allow the Computer to turn off this device to save power”. (My Passport sleeps anyway - Only the USB - interface kept alieve)

Try this and it “might” solve your wakeup issue. If possible try using hibernate option instead of standby or sleep option.

More importantly, if your laptop is only designed for Win XP and you have upgraded to Vista/Win7 by just adding more RAM or so, would prompt this kind of issue. (Device driver incompatibility issues) (I am sure My Passport is the real culprit and it needs REAL firmware update so badly)

Please note that you must remember the USB port you used to connect My Passport. If you switch My Passport to another USB socket would resume your current issue.

Mabikay – SLK


He said " If I reboot my notebook, it will work fine. But when I put it to sleep, and then I wake it up, this problem arises." in his initial post.

I have replied accordingly and lets see the outcome…

Mabikay - SLK

This notebook had Vista installed on it when I bought it, so that’s not the issue.

I will try your workaround (which I admit sounds a bit speculative to me) as soon as I can.

This issue has already ruined my day, but I need to get some work done anyway :-/

Thanks, and I’ll post an update.

Just for the record. I deactivated all virtual drives to see if it changed anything. It didn’t. Then I reactivated them. I saw in drive manager that they were now in higher CD-ROM slot numbers. I deactivated them again, and the WD disk. Rebooted. Reactivated virtual CD-Roms, plugged the WD disk. Now I can put the computer to sleep, and when it wakes up it sees the disk again. It doesn’t make any sense, something has changed but it is impossible to know what. When it’ll stop working again I will try to reflect on the last things that were done before it stopped working. The malfunction seems random to me.

Also, I wrote to WD. They asked me a few questions, and to do a few tests. No test provided any new indication, error message or such. Then they concluded that it was a power management issue and that I needed a booster cable. They took my street address and they will send me the booster cable. It’s kind of them, but I don’t know if it will work. Also if the booster cable needs to be plugged in a wall socket, that will ruin the usefulness of the disk. At least it will help to diagnose the issue.

Thanks for your suggestions.

So called Booster cable is a Y cable that comes with two USB-A male jacks. You have to scarify one more USB port in your PC to power your portable device. Pity!

They made an error and sent a plain cable. Now the problem is happening again so I may ask them to send the proper cable

I asked WD to send the (booster) cable they wanted to send, and I received it, but unfortunately that doesn’t help, the behaviour is the same as with the normal cable, i.e. I get the “WD SmartWare” partition with utilities, but not the data partition. So, it doesn’t seem to be power-related, and it is more likely that it is a software issue. That is confirmed by the fact that after tinkering recently with virtual drives, it worked for some time… So right now I need to reboot if I want to do a backup.