No WD2go Remote Access on Connection After Changing Routers

Hi. Was hoping someone would be able to help me with a problem i’m having.

I bought a WD My Book Live Duo (6TB); the WD2go (both app and web) worked great, but I found the streaming performance a little sluggish due to my older Linksys E2000 router.  I then bought a Linksys EA6500 router, which greatly improved the streaming.

However, after switching the routers, my WD2go (both app and web) access would not work.  When I went into the “Remote Access” tab in the “WD Dashboard”, I discovered my connection status was “failed” (Error 31520).  No matter what i did (dis-able/re-enable, rebuild WD2go server, push reset on back of MBLD, etc.), i could not get a “connected” connection status.

During the trouble shooting process, i hooked up my old router to the MBLD again, and it then had no problem getting a good connection status.

Its not the WD2go app on my devices, the app work perfectly whenever I hook back up the old E2000 router.

I’m not sure why it is doing this. Did the MBLD become set with the IP address of the E2000 router I originally hooked it up to?  How can I change the MBLD to the IP of the new EA6500 router and get a good connection status for remote access? Or Is the MBLD connection process not compatable with the EA65000?  Or any other ideas?

Thanks for any help.

See page 44 of the user manual for your router (US English, at least) on how to configure UPnP.


First off, thanks for the product guide; the installation disc for the EA6500 came with a downloadable PDF product guide, but for some reason, that one is less then half the size of the one you provided and has much less info.

Now, concerning the connectivity issue, i’ve been looking at all the setting for both the MBLD and the router.  I signed into the router page before and made sure the UPNP was selected.  I just unselected, applied, then selected it again, and applied again, but the WD dashboard still says no connectivity.

However, when messing with the connectivity settings (switching the network mode back and forth from static to DHCP) in the WD dashboard I keep getting a pop-up notice which made me say earlier that I thought the IP settings were stuck on the previous router’s IP - though im not sure this makes sense, as I dont have a lot of knowledge in that area.

The notice is below:

I also tried switching routers again, and the results were the same. 

When I hook back up the E2000 router and go to the WD Dashboard (which shows up under the E2000 router’s IP address), the connection status is good and I can access the MBLD from the WD2go app or website.

But, when I hook back up the EA6500 router and go the the WD Dashboard (which shows up under the EA6500 router’s IP address [different from the E2000 router’s]), it keeps saying “connection failed” and when I try to access the MBLD from the WD2go app or website, it says the device is “offline”.

Not sure why I get remote access connectivity using the older (and slower) E2000 router that I originally hooked the MBLD to, but not the newer EA6500. Extremely frustrating; especially as being able to remotely access my files from home while I was at work or anywhere else was the primary reason I invested so much money in this device.

Any additional ideas or help would be greatly appreciated. Last thing I want to do is reset the MBLD to factory settings to try and see if the new “initial” connection with the EA6500 takes.  I’ve found the transfer rate for the MBLD to be terrible (4-6 MB/second) and its taken me weeks just to transfer over the 640 GB of data I have on it now. Would be horrible to start all over again. Thanks.

Reset the MBLD by holding the reset button for four seconds.  Then redo the installation.

Hi Tony,

Thanks for your continuing help; I appreciate it.

I actually tired the reset a few days ago, but it did not work.  I tried it again twice tonight, but I still have the (no) connectivity issue.

Frustrated, I finally just went and did a factory restore of the MBLD; then started the installation process with the new EA6500 router hooked to it from the start.  Unfortunately, after the set-up, my remote access connection status still failed (Error 31520). When hooking up the old E200 router, after the factory restore, the issue was gone and I again had a good connection status; hook back up the EA6500 - and nothing.

Now i’m wondering if there is a compatibility issue between the WD MBLD (6TB) and the Linksys/Cisco EA6500 router? I dont know.  Spent quite a bit on both so frustrated that its not working; especially as these are both the top of the line models for each.  Not sure what to try next.

Are you using the “Cloud” Connect feature?  If so, you might try with it disabled.