No Subtitle Options after the latest update

I own the latest WD TV Media Player (WDBYMN0000NBK-HESN) I’ve used it with my wireless hard disk and it worked perfectly. But since I have upgraded it, I can’t seem to view any subtitle option. Although, I have tried to access similar files that I’ve viewed before the update. I really wish I haven’t updated the system. It really did nothing but trouble. The subtitle button on the remote does nothing. and when I choose Options nothing related to subtitles is shown. 

Please help.

have you tried a factory reset after upgrading the firmware ?

Setup > System > Device Reset > Reset All Settings Back to Factory Default

Edit: just double checked my wdtv … subtitles via options and subtitle button working fine (Firmware 1.02.17)


Thank you for your reply. 

Yes, I’ve tried what you suggested and many other attempts including:

  • Connecting to a hard disk wirelessly with Wi-Fi enabled (this was the way it worked before the firmware)
  • Connecting to a hard disk directly with USB cable
  • Playing different movies and TV shows that used to show subtitles on screen
  • Enabling subtitle default from Video Settings

This problem is really annoying, I can’t really make a use of the most important feature in WDTV.

  • Subtitles button on remote control still not usuable and does absloutely nothing
  • When entering options menu after playing some parts of a video, there is no subtitles options at all. They are just gone. 

I’m thinking it could be an issue with the 1.02.17 firmware . It might have been installed partially or some other software error. If I only know a way to reinstall it again or just downgrade it to the previous version, it would be great!

Sure, you call rollback the firmware to the previous one.

download Firmware 1.01.30 from here to rollback,-wd-tv-live

because subtitles are working fine for me on 1.02.17

how did you update ?   OTA or via USB ?  …

personally i always do it manually via USB (in case my internet goes flakey during the firmware update)

UPDATE: Okay, I have downgraded the firmware and tried to enable subtitles from my FUEL LACIE wireless hard disk. However, the same results were shown. No subtitles. So I tried to transfer a movie file with its SRT file to another hard disk and connect it directly to WD TV and it was perfect. Subtitles are visible with all the options.

It seems to me it is related to FUEL LACIE wireless hard disk. Appearently, it has a mind of its own. Sometimes it works and sometimes it doesn’t … It is worth mentioning that its wireless signal disappears from time to time when switching it on and I wasn’t able to connect to it several times. It could be signal interference?

I may not be able to use the wireless feature for now, but I’m glad that I could at least view the subtitles whenever I please. I hope this issue is fixed by whoever is responsible. 

well it could be something wrong with your LACIE

personally, i’ve had no troubles with the WD My Passport Wireless

Only thing i can think of … are your subtitles “embedded” within the video file or are they “seperate / external” files ?


The Avengers.mkv


reason i ask is because, “separate / external” subtitle files won’t work using “Media Shares” aka. DLNA (srt subtitles must be embedded to work)

using “Network Shares”  subtitles will work fine, either way (embedded or separate / external)

check your LACIE settings and check you’re using “Network Shares” on the WDTV