No sound on WD TV Live

I one day sound stopped worked on my WD TV Live.

Firmware 1.05.04_V


I use HDMI, sound settings is on “digital pass-through”. Tried on different TV. Also tried to switch to composite - the same. Sound not working :frowning: Anyone faced a similar problem?

Did your unit come without a case? Any reason for the picture.

Just remove the case ) This just a picture without reason. Btw, there is a sound chipset on board?

No, the same processor does both video and sound.

Try downgrading to a previous version or you can try installing WDLXTV. GOOGLE for the URL. WDLXTV has added diagnostics which may or may not help you to diagnose your problem.


if you are using hdmi [for audio] : try to change   [in on-screen options of  WD HD]  sound to  “stereo”  and check again.

pls revert here back if that worked



I agree with pawson. The issue is that you have it set to Digital Pass Through in audio. The problem is that most TVs, unless they have the DD/DTS logo on it, don’t support decoding of digital audio. Change your audio settings to Stereo on the WDTV Live. I have opened up a new thread about this as a feature request. I hope the engineers take into consideration my new feature request. I have requested for there to be a setting/option to choose Stereo via HDMI and Digital via Optical. Most people, unless theyu always use the home theatre system to output sound, have this kind of setup anyways where the HDMI is connected to the TV and Optical is connected to the home theatre receiver.

den43 wrote:

Just remove the case ) This just a picture without reason. Btw, there is a sound chipset on board?

Also, you might want to try it with the case on it.  You never know.  :smileyvery-happy:

Kidding aside, digital passthrough directly to a TV that doesn’t support digital audio would be a problem - although if it has HDMI Inputs, then I would presume it supports many levels of digital audio but agree that probably not the hight bitrate modes such as DTS-MA, TRUE-HD, etc.  Likewise, maintaining the same setting, and “… tried to switch to composite - the same” would result in the same symptoms (but for different reasons).  You didn’t say what audio format you’re trying to play so it’s a ■■■■-shoot.  Set to Stereo as suggested.

thepanoguy: I have installed wdlxtv, but have no idea how to diagnostic. Could you say any advices?

this not helped. :frowning: