No network with USB N10 asus


jus bought and connected the Asus USB N10(on the compatible list and correct rev no) to my WDTV Live. tried both manual and auto detection and the correct encryption method and key. Error msg is “unable to obtain an ip address. teh media player has limited or no network connectivity”. following observed: -

  1. the light on the adapter blinks when connected to both usb ports.

2. in auto mode it displays my network but shows no signal strength. on the same spot, when i connect my adapter to my lappy, shows full network and im accessing the internet. so the adapter works. 

  1. my firmware is 1.04.10_v.

 Pls Help…!

Hi there, if the media player doesn’t give you the option for wired or wireless connection before selecting automatic or manual, then your adapter is just not working with the media player…

it does give me that option before asking me for automatic or manual connection option.  there after i also get to see my connection on the display but thereafter the error msg apears…any ideas?

just for testing I would drop the encryption and key on your wireless and see if all ok then, if so, you will now it’s the encryption or key which is causing the problem.

1 Like

dear markinuk,

   Thanx a ton for the idea man! it works like a charm now…!! i had beaten myself up with all possibilities for this… but now comes the second part; what could be wrong with my encryption and key? 

 i have the same brand router(ASUS) and it initially had a shared key with WEP encryption (which is not very strong) in the first place… i don wanna be without encryption…

 thanx again for the first eureka though!

You want to be on WPA or even better WPA2 encrypyion

first try WPA with a key which only has letters and numbers (no special characters in the key)

if ok, wack it on WPA2 to try with the same key as the WPA one.

That’s about as much I know for you to try, I’m sure TonyPh12345 will be able to offer you more help if needed.

thanks a ton for the advice… i tried WPA with only 8 numbers and it worked. Wonder why  the compatibility fuss is with all these characters and encryptions…

the WD is fussy about special characters being in a key, just stick to letters and numbers only and all will be fine.