No longer recognizes external HD

I would appreciate any help with this.  I’ve been using and really enjoyed the live hub media center for about 6 months now.  I also have a couple of external USB HDDs that I have a lot of video content on.  The external drives are WD My Book 1.5 TB drives and they have worked great for months.  They are formatted as NTFS.  They have always had the issue that the media hub takes an inordinate amount of time to initially read and scan through it to see what is on there before I can use it, maybe 5 minutes, but then it’s good to go.  About 1-2 weeks ago, I began to notice that I can no longer access these drives.  They won’t show up if I plug in the back or the front.  I also have a small 8gb thumb drive that I use to put small amounts of data onto the internal drive and it still works w/o any problem.  It is FAT32.  I think it may have started since I updated to the 2.05.08 firmware.  Thinking that may have been the problem, I downgraded the firmware to a previous version, 2.02.19 and it still has the same issue.  Any idea how to resolve this? 

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


As a complete guess, it sounds like the drives got corruped by not being safely removed… you have been “Ejecting” the drives prior to shutting down, right?

Ive never ejected a drive in all the years Ive used WDTV boxes, and they are fine.

Why dont you connect them to a PC and if they work ok, its an issue with the Hub.

wdtvhub wrote:

Ive never ejected a drive in all the years Ive used WDTV boxes, and they are fine.

Do NOT put data on an external USB drive that you can’t afford to lose. There have been a number of reports of data corruption or total loss of data if the drive isn’t properly ejected from the WDTV before unplugging or powering down.


Yeah fair points…but I never have had any problem.

Thats also like saying lets hope the Hub never crashes, as how does the hard drive/s have time to shutdown correctly.

And the way these guys with all the Netflix problems have been having, maybe they can claim :slight_smile:

And as far as the WDTV 1 went, all you could do was rip the power cord out of the back when it used to hang, it never went out of standby.

True… I’ve unplugged USB drives, even from Windows, without “Safely removing” them, and avoided corruption.  But that’s just luck… the very next time could be the time I lose everything.

I have had drives that needed to be repaired because my Gen1 corrupted them when powered off “normally”… I’ve tried to remember to “Eject” ever since.

On the one hand, it really is something folks should be doing, just to avoid the possibility of problems, even if the odds are fairly small of things going badly… but on the other hand, all I can see in any of the manuals is that you should Eject before disconnecting the drive… the manuals don’t make the same “before power down” recommendation that Customer Support and Bill and several members feel is prudent.

I´m having a similar problem. I tried the USD drives on my computer and they work fine. The Hub is just not detecting my several USB drives. Help :cry:

Yeah, I’m not sure what the deal is.  I have a 1.5 TB WD MY Book external drive and I’ve got just a bunch of TV series on it, nothing too important.  It works fine through my PC.  Plug it in, detects normally, access all the content as it should.  Plug it in to the hub and nothing.  It worked fine for months, no issues, then one day, it’s like it wasn’t there.  Same thing w/ another drive, worked fine, then nothing but I can still access it normally through PC.  I have 2 drives that it will access now.  One is a small 100gb Maxtor and the other is just an 8gb thumb drive.  Both are detected normally and it scans the drives and it’s up and running on the hub.  I have no clue what the deal is.  I’ve down graded the firmware to a much earlier version and the same issue.  Just got the newest version 2.6? and still nothing.  I guess I’ll just have to go to trying to share from my networked pc and stream when it runs out of space.  Still ticks me off that it just went flaky on those other drives.  The whole reason I bought the 1.5tb is to use w/ this stupid hub.  (yes, they were always ejected too). 

Johnboy:   Here’s a little test you could try out, if you’re in to experimenting with software:

Go download the UBUNTU LIVE package.   This is a bootable CD or Thumb Drive that lets you run LINUX directly on your PC without doing ANYTHING to your existing Windows install.   Remove the disk and next reboot it’s back to windows like nothing changed.

Anyway, the Live / Live+  / Live Hub are based on Ubuntu Linux.   See the GPL code for the WDTV Live to see which version of Ubuntu is being used.

So you can boot on an “equivalent” Ubuntu Live Package and see if IT recognizes your USB drive.

If it DOES, then that tends to point one direction.  

If it Does NOT, then it points in the direction of the problem being the UBUNTU LINUX operating system, and the LOG FILES in Linux can give LOTS of details as to what the problem actually is.