No lights - is my Gen 1 dead?

My 2TB Gen 1 MyCloud has stopped working. The drive is spinning but I get no lights at all, front LED nor on the Ethernet port. I can’t access the drive through either the network of using a USB lead. Removing the drive and hooking into a Linux machine, my data is all there and accessible. Is my board irrecoverably dead?


The USB port on the My Cloud device is not used for connecting to a computer, its only for connecting devices like USB hard drives.

Can you access the My Cloud Dashboard (when the My Cloud is connected to the local network)? Some have reported that their front LED has stopped working but the device continues to operate normally.

One could attempt to restore the My Cloud firmware to their My Cloud hard drive using one of the various unbrick methods mentioned in this subforum. Use the forum search feature, magnifying glass icon upper right, and search for “unbrick”. Note that many unbrick processes may erase all user data. Backup that user data before attempting to unbrick just in case.

User Fox_Exe has a set of unbrick directions for the first gen My Cloud that some have used to restore their My Cloud or to replace a My Cloud hard drive to a larger size.

The main Fox_exe repositories for multiple My Cloud models can be found here:

First gen directions:
The img files needed for the first gen Fox directions can be found in the WDMyCloud-Gen1/Backups folder in the main Fox_exe respoitory link above.

Thanks for the suggestion Bennor.
I can’t access the dashboard, or indeed get the drive to show up on the network in any capacity. It looks like there is no ethernet activity (no lights on the port). There is definitely power going to the unit though as the drive is spinning.
I ma going to try the unbricking process using an old hard drive so as not to risk my data. I’ll let you know how I get on.
Thanks again


Had a go at the unbricking process as suggested. Tried a number of times using various configurations, without any success. Still disk spinning but with no lights and no ethernet connection. I think I will declare the board dead and buy myself a NAS housing to transplant the drive into.
Thanks for your help.


Yes sounds like a dead board. If there are no network lights and no front LED light. One possibility is to check various websites like eBay, Craigslist and the like. One may be able to find the same model (first gen v4.x or second gen v2.x) of My Cloud enclosure where one could simply transplant the drive and hopefully be back up and running.

However, considering the age of the single bay/single drive My Cloud it may be better to buy a newer NAS drive (not the My Cloud Home) and either use the old My Cloud drive in the new NAS or put the My Cloud drive into an external USB enclosure and attach it as extra storage to a newer NAS.

sorry for being slightly off topic but …

you should keep a backup of your data no matter what. If you don’t have a backup, then you risk your data every day … even when things are working fine, disaster can strike at any time.

I have a Gen 1 My Cloud 2TB … all the data on it is backed up on a 2TB WD Elements hard drive … so if my Gen 1 My Cloud bites the dust, i have a copy/backup of all the data on it.

If no front light - its a dead bootloader or hardware problem.
When you power on device - front led is set to white by bootloader. Then - changes to red/blue/green by linux kernel or OS (Firmware).

Maybe CPU still live, but damaged bootcode on internal SPI-Flash chip. You need unsolder it and copy data from worked chip from another (worked) device. Also need SPI programer or Arduino for read/write to this chip.

So… Its not for regular user… Throw it out in garbage…

Thanks Fox, that is definitely above my ability level.

Before I throw it out, if there is anybody in the UK who wants to see if they can resurrect this board, or wants it for spares, I am happy to post it out to you. Just let me know.

Sell it on E-Bay :slight_smile: