"No internet access" even with port forwarding


I got my WD over the weekend and have not been able to get it working outside of my home network.

What works fine:  I can access files on the WD using TV’s DLNA.  Also using the static IP, I can also access content via ES File Explorer on my tablet.

Here is how I’ve set things up with the “my cloud”.

My WD sits behind a Linksys WRT54G router which in turn sits behind a SB6120 modem ( Comcast ).

I have setup a static IP ( outside of the DHCP range ) for the WD.

I have enabled port forwarding on the router for ports 80 and 443. 

I still see “No internet access” on the UI settings.


  1. Is there something I should be doing on the ISP side with Comcast to make the WD visible to the outside world?

  2. Is there a way to look at the log files to see why the “No Internet Access” is occuring ? If yes, where are the log files on the WD ? 

  3. Would it be possible to do a telnet to port 80 on my router and see it being logged in the WD log files or the UI ?  I want to be sure that the port forwarding is at least happening.

Any help is greatly appreciated.


Forward the external router port 8080 to the NAS port 80, and the external router port 8443 to the NAS port 883, using the router UI.

Then, using the NAS UI, indicate that yor are using port 8080 and 8443 for the port forwarding setup. Turn on remote access, and set up at least one user for remote access. This will force you to set up a wd2go.com account for that user.

Reboot the NAS. Verify in the UI that remote access is enabled

1 Like

Thanke Etupes!

I’ve setup port forwarding properly now.  And can access my share from my phone.

Just one thing though. 

When I go into Settings->Network I see the Network Status as " Internet Access". This looks fine.

But when I go into General->Cloud Access->Connection Status. It says “Connected ( Relay connection established)”. Right below that message it also says “Port forwarding failed to connect on port 8080 and port 8443.”

Is this a bug in the display ? I am using firmware version “WDMyCloud v03.04.01-230”. 

Yeah… With this firmware, the switch to direct connection might take a reboot of the NAS. I have not been able to pinpoint the way to solve for this.

Recently, I switched to UPnP settings on the router, and Auto setting on the NAS. With UPnP, you wouldn’t need to specify which ports to forward.

The drawback is that you don’t know which external ports are being used.

I do have skype doing Upnp through my router. I will try Upnp too.

Thanks again !