No Dolby Digital Sound Via Amp

I recently purchased the WD LIve TV Hub with 1TB and after setting it up the firmware was updated (2.08.13).  I have connected my Hub to my Amp (Yamaha A1) via the optical and made the necessary changes in the Audio settings i.e. ticked DTS, Dolby Digital etc.

I have tried to watch movies (MP4, avi, MKV etc) and noticed that that I do not get Dolby Digital surround sound from my amp even though I know for a fact that the audio stream is Dolby digital 5.1:

  1.  When I stream through via the PS3 Media Server and by using transcoding, I get Dolby Digital sound through my AMP.  

  2.  I then tested the same movie file through my PS3 and voila I have Dolby Digital 5.1 surround sound.  

  3.  I have also tried unticking  the DTS, Dolby Digital in the Audio Settings and ticking the AAC, when I do this and play the movie file, the AMP shows Dolby Digital but there is NO sound.

  4.  I also tried to roll back the firmware several times and tried the above points 1, 2  and 3 but still can not get it to work.

I am surprised that I cannot get this to work for the life of me as I have tried everything in the settings etc. I wonder if anyone else has had any similar experiences as I have and if they managed to resolve this issue.

Please help!!


Ace a couple of thoughts, no solution, just trying to help where I can.

It’s not the firmware.  I have the latest/greatest and durn near rattled the giant mirror (wedding gift not narcissist) off the wall in the den when I cranked up Monsters Inc. earlier tonight using DD over optical.

Here’s a long shot, after much nashing of teeth I found that I needed to hard power down the unit to get my WDTVLH to recognize a config change.  Just throwing that out there to make sure you’re hard powering down the unit (hold power button or remote button for 3 to 5 seconds).

I’ll follow this thread as time allows and wish you a speedy fix discovery.


Hi Jim

Many thanks for the post and your suggestion, I tried the hard reboot but unfortunately it did not work.  Its quite odd really, I have saved some movies on the hard drive and tried to play them hoping to get Dolby Digital sound but that again that did not work.  It seems as though the WD TV Live can not extract the relevant audio files from the movies and I am now definitely sure that this is a software/firmware issue with the unit.



Something is not right here but I cant put my finger on it…

This is all you should need to do. I know you have but humour me here…

Audio Output / Setup

Select Digital Pass Through Via Optical Only

Select DTS capable receiver…

That should be that.

Now something you have said confuses me, you dont say what your AMP says when you do get the sound ? If the sound gets to it, it will be what it is, if its only stereo then there might be a problem with the box. What I really don’t understand is, if you selected AAC and it was not AAC why it would show Dolby Digital when you get no sound, I am no AMP king, but if no sound goes to my AMP, I get no sound that simple and nothing would be displayed.

Have you tried another optical cable ?

Hi there

I have selected the Dolby Digital & DTS capable receiver in the Audio Output (Digital Pass Through Via Optical Only) settings.

The only time when I get no sound is when I choose AAC capable receiver, and the AMP shows Dolby Digital?? when I deselect AAC capable receiver I get sound but the AMP shows Pro Logic only.  It looks like that the WD box is sending conflicting information to the AMP??

I tried a new optical cable and its the same story.

What is interesting is that a few moments ago I tranferred an indian movie (mkv) with DTS onto the internal hard drive and when I play this file directly from the hard drive I get DTS surround sound.  I then tried another indian movie (mkv) with dolby digital and it plays Dolby Digital sound, the AMP on both occasions shows DTS and Dolby Digital respectively.  So the situation now is that I think the problem lies with the unit not being able to read the correct audio files in the MP4 format .

Is there a way around this?

I see.

So your saying that Mkv files work ok, but MP4 files do not ?

edit - Ah I see it says Pro Logic…

Well it could be the way the MP4 files are coded. I am not sure, use this App

and paste an offending file info in a post


I have some info from Media Info


General : \VENUS\Venus C160\Torrent Files\Rio (2011) BRRip 720p x264 5.1ch AAC-SiNiSTER\Rio (2011) BRRip 720p x264 5.1ch AAC-SiNiSTER.mp4
Format : MPEG-4 at 2 275 Kbps
Length : 1.52 GiB for 1h 35mn 57s 867ms

Video #0 : AVC at 1 890 Kbps
Aspect : 1280 x 528 (2.424) at 23.976 fps

Audio #0 : AAC at 384 Kbps
Infos : 6 channels, 48.0 KHz

This movie is only playing Pro Logic

Dabaang - Indian Movie:

General : \WDTVLIVEHUB\WDTVLiveHub\Movies\Indian\Dabangg 2010 Hindi 720P BRRip x264 E-SuB xRG\Dabangg 720P BRRip xRG.mkv
Format : Matroska at 3 417 Kbps
Length : 3.01 GiB for 2h 6mn 1s 988ms

Video #0 : AVC at 1 906 Kbps
Aspect : 1270 x 544 (2.335) at 24.000 fps

Audio #0 : DTS at 1 510 Kbps
Infos : 6 channels, 48.0 KHz

This plays fine with DTS output.

Look forward to your post.

Question, is your reciever capable of multi-channel AAC, just because it’s AAC compatible does not mean that it will handle multi-channel AAC.