No Devices Available / Remote connection issues

Hey everyone. I bought a My Cloud mirror a couple of days ago and have been experiencing some problems with the remote networking. Any help is appreciated, so here it goes (btw i’m using a Macbook Pro):

  • When I initially connected the device, I attempted do the setup via the My cloud set up website. I would get a message saying that no device was being found on my network. I rebooted my computer, router, and My Cloud a couple of times, and finally I was able to complete the setup.

  • Since then, the device works well on my network through Finder, however I am not able to access my device remotely using the mycloud.com. I tested to see if my router or ISP are the culprit by connecting remotely with my Iphone using the MyCloud application through LTE (not wifi) and it works!

So here’s where I stand:

  • I am able to connect to the MyCloud device through my home network using Finder and the My Cloud Dashboard, but NOT through a browser (Safari or Firefox in or out of my network). I am also able to connect with my Iphone using the IOS application, OUTSIDE of my home network.

So aside from my Iphone, there is no way of connecting to my device outside of my home network, but I am still not understanding why I cannot connect to the device via a web browser even on my home network (although I can access the router settings!). It keeps telling me “No device available” via mycloud.com. I also tried to run the setup again, and it’s giving me the same message,

Does this make any sense? Please help!

Does the Router you using have a Firewall, if it does it will block access unless you creat an exception. Had similar problem with my Netgear.

Forgot to ask if you have latest firmware and sofware. I is the background to your Dashboard black,its old if it is. My Cloud should show in network. I use Windows 10 and you mention Safari so you run a fruit I presume.

Hi John,

Thanks for the quick response. I suppose it does. I own a D-Link DIR-655. I am not at home to check, but here’s an emulation of my router dashboard: http://support.dlink.ca/emulators/dir655/121/Firewall.html

I am running the latest firmware on the MCM and yes, I’m running a fruit :wink: