No confirmation for Completion of syncing

Hi there,

I am working on a Mac and I have a WD My Cloud set up in a remote location. I tried using the online version, the desktop application, as well as the WD Sync application, however not one approach seems to have a way of confirming that all my files have been transferred. I transfer a large amount of pictures at a time, which take days to sync. I don’t even know if it should take this long; for about 30Gb it took me about a week of constant syncing, day and night. I can not “bulk” count the number of files that are in a directory, I do not get a confirmation notification, there is no “signal” that shows that a file has been synced (like the dropbox green check mark). I emailed customer support and their answer was that they simply do not provide this feature. Before I give up on this state-of-the-art useless software solution, did anyone find a workaround for this problem?

Thanks in advance,


Before I give up on this state-of-the-art useless software solution

I’d suggest this option, and look at alternatives, such as FreeFileSync…

Note that the speed of copying or syncing files remotely will depend entirely on the broadband speed at each end of the connection. Trying to transfer 30GB over a broadband connection will take some time (many hours to days) as many broadband providers have slower (sometimes much slower) upload speeds than download speeds.

As the previous poster indicated look into using alternative software, like FreeFileSync, if the WD software isn’t working for you.

Do you have some suggestions as to how I could add the WD drive to the FreeFileSync. From what I’ve understood you seem to need to be on the local network to be able to map the drive as a remote drive.

It gets added like anything else when one clicks on the Browse button to add the location. The My Cloud will be listed (unless you have the Windows 10 My Cloud issue mentioned in other threads) under Network, from there one can select the share, or navigate into a folder within that Share to use as the folder.

Edit to add: The My Cloud can be added like any other local network device:
\\wdmycloud\<share/folder name>

Mmm that’s the issue then. As I am not currently on the local network. The drive is set up in a different location (different country, so really not accessible).

I guess this is also the reason why I don’t have any Network directory listed either.

One option to access the My Cloud remotely is to use SFTP. Then one can use the SFTP option of FreeFileSync to sync files. One will need to activate FTP within the My Cloud Dashboard (Dashboard > Settings > Network > Network Services > FTP Access = On). Then configure the router of the local network the My Cloud is on to port forwarded SSH SFTP: 22(TCP) to the My Cloud.

See the following FreeFileSync Manual link for SFTP support: