No Authentication on NAS. Open Access


#1

Simple question but how do I set the shares so that you do not need to authenticate in order to view edit and delete files on the NAS?

Cheers

Glyn


#2

go into advanced mode, users, folder share permissions, click the modify button next to the share and add guest to full access


#3

Thanks for your post but I have tried this and it does not work. I always get prompted to authenticate.

Cheers

Glyn


#4

man smb.conf

http://www.samba.org/samba/docs/man/manpages-3/smb.conf.5.html

You have a few options and you will need to read the documentation to decide which is best for you, any changes will involve enabling ssh and accessing your sharespace via ssh using a terminal emulator to edit the smb.conf file which lives in /etc/samba/smb.conf

the particular the settings you will want to look at are 

security = (but note if you change this to ‘share’ you are downgrading your security)

your other probably better option is to look at 

map to guest = Bad User  ; this will automatically map unkown user accounts to the guest account. 

-----

Any Update on our Update Bill_S? We wait patiently for a fix… 


#5

None, yet.  Sorry…