No audio from Nikon Coolpix .avi video


#1

I have a Nikon Coolpix L20 that will record home videos.  It records in .avi.  Windows media player will play the audio and video effortlessly.  The wh hd tv live will play the video but it says audio format not supported. Anybody have any solutions?

Thanks in advance


#2

The audio in the videos is either encoded with a codec unsupported by the WDTV, or even uncompressed. Check if it is the case with an application like G-Spot, which gives you detailed info about avi files, or play the video with a media player like VLC, MPC, etc… which also give you that info.

In case you need to reencode the audio you have programs like Avidemux that can do that for you.


#3

Download Mediainfo and take a look at the video. This will tell you and us what audio and video stream it has.

http://mediainfo.sourceforge.net/en


#4

First of all, thanks to all for your responses…

I downloaded the file above and “input file” for audio it says…

64 kbps

1 channel

8000 hz

format:  ccitt u-law

Feel certain the problem is with that unusual  format…

Wish I had a way to change the audio format, but l20 is intro camera and dont see a way to change…

Thanks for everyone’s help…

Any other advice regarding  this topic would be appreciated…


#5

You definitely need to transcode the audio, that one is a codec used for telephony, and it’s really no wonder that the WDTV live can’t play it.

There’s a couple things you could do to play those files. One would be playing them thru TVersity: just put all the videos made with that camera in a folder, and when you add it to TVersity’s library click on the advanced button and select  “always” transcode. That will probably be the easiest if it works. If it does work you can try switching to “transcode when needed”, and that may transcode just the audio.

If you wanna modify the videos to play directly on the WDTV without a media server you could do the following:

-try with a program like Avidemux. If it can handle that codec it would be quicker than other options:

http://prdownload.berlios.de/avidemux/avidemux_2.5.2_win32.exe

You can simply open the video with that app, and change the “audio” combo box on the left side from “copy” to one of the available codecs, like MP3 (lame). Then you just save it with a different name, and it should be done in a few minutes.

If Avidemux doesn’t work there’s another thing you could do, but a bit more involved:

  • open the video with VirtualdubMod

http://sourceforge.net/projects/virtualdubmod/files/VirtualDubMod%20bugfix_cvs/1.5.10.2%20build%202542/VirtualDubMod_1_5_10_2_b2542.zip/download

  • go to the “streams” menu, and then to “streams list”

  • there’s probably just one audio stream, just select it and press the “demux” button on the bottom right corner of the window. It will prompt you for a location to save the audio stream, probably with a .wav extension.

  • now you can transcode the audio with one of the many audio tools that transcode between different codecs. I suggest Foobar2000. You would just open or drag the file to the foobar2000 window, and select “convert” with a right click. Then when you get the conversion window you select MP3 and click OK. The first time you run a conversion it will ask for the location of the lame.exe encoder, if you don’t already have it somewhere download it from http://www.rarewares.org/dancer/dancer.php?f=226

  • when you have your .mp3 file, remux it in the original video with virtualdubmod again. Just open the video, and on the “streams list” double click on the original CCCIT u-law stream to disable it, and click on the “Add” button to add your new mp3 file. You’ll need to go to the video menu and select “direct stream copy” btw, otherwise it will also reencode your video. Then just save it with a different name and it should remux the file in a couple minutes at most.


#6

Thanks again for such thoughtful input.  Will try one of these work arounds!