No access to My Cloud - solid yellow

Hi everyone,
I have a 6TB My Cloud which was working good (a little slow but good), but after my modem broke, rent one from my internet provider and never work again after this.
I already tried the 4 and 40 sec reset and continue with solid yellow.
I read about this and is clear for me that this is a Network issue and maybe the device did not finish the reboot process, but how I can make it work.
Device is never online, so I can not detect it via Dashboard, I cannot update the firmware to OS5, nothing.
I am starting to think about remove the hard drive and access the data, but I am wondering if there is a way to fix this and continue using the device as before.
Any comments / suggestions are welcome.
Thanks in advance.

What router did your internet provider supply to you?

Its rare but there are certain routers that can cause issues with the My Cloud. The workaround (or troubleshooting step) is to use a network switch between the router and the My Cloud.

My Cloud is not recognized when connected to AT&T Uverse, Pace, Arris, Ubee or Sonic Gateway Routers

Other troubleshooting steps. Make sure the My Cloud is connected directly to the network router and not to an extender or access point. Try a different network cable to connect the My Cloud to the network router. Try accessing the My Cloud Dashboard if you haven’t done so already to see if it is accessible. Try connecting the My Cloud directly to a computer that has a Ethernet networking port to see if the My Cloud will boot properly. (How to Access a My Cloud When Connected Directly to a Computer)

If one has a second generation single bay My Cloud (P/N number ends with “-10”) or they have an OS5 supported router it is possible the router updated to OS5 v5.x firmware automatically. If this has happened then its possible the My Cloud is hung up on the indexing of the unit. See the following OS5 knowledgebase article from WD for more information about OS5 and some links on the indexing issue.

My Cloud OS 5: Online User Guide and Solutions

Thanks for your quick and detailed feedback.
My current internet provider is Wow and gave me an Arris Modem DG3270 which has a 2.4GHz and a 5Ghz networks.
I did try changing the ethernet cable.
I saw that some Arris modems have issues, so I will try a different modem or adding a network switch in the middle and test again.
I tried in the past connecting directly to my laptop but did not work…I recently changed to a new laptop and this one does not have a Ethernet port, but I am using a docking which has one, also tried here and I was not able to connect to My Cloud.
I also download the Dashboard App and is not detecting any devices.
I download an APP to check the IP Addresses in my network and few of them does not have a description so I was not sure if My Cloud is showing or not there, but considering that the solid yellow LED means network issue, I assume will not show because is basically the issue I have.
I will let you know after trying with the network switch or different modem
Thanks again

If using Windows there are a few things to check. First is enabling SMB1.0/CIFS in Windows. Second is ensuring the Windows Network Profile is set to Private. Third is to check if any third party security, firewall, antivirus, malware program(s) to ensure they are not blocking local network access to network devices.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10

Thanks again,
I just enable SMB1 in my laptop but I still cannot see My Cloud device here or in the Dashboard

LED remains solid yellow as always

I just ordered a network switch and looking now for a different modem to try this