NFS share and folder images issue


Has anybody else experienced issues with NFS shares and how folder images operate?  Or don’t operate  :slight_smile:

I recently switched NFS on for my main media share from my NAS and when I view these folders I only have 1 folder image that actually works.  If I switch back to samba all the images work as they did.  I don’t understand why only one works and the others don’t.

Under NFS I no longer have any folder images replicating up to the folder view for my tv shows folders which are separated out in separate folders per Tv show (using meta.thumbs).  Under Samba the content info image that is shown for the file is also shown for the folder when viewing a level up.

I also noticed that for the media files where there is no image content for the files in a folder it does not show an image from the video on the folder view as it did under samba.  Although this has always been strange to me as some folders will do this and some wont under samba.  My video camera .mts files allow this.

In terms of what I tried to make the pictures work, I have cleared the media library, performed a device restart, and also deleted the .wdtv folder from the NAS drive and let it rebuild.  (Still only the one folder will show the folder image)

Is this normal under NFS shares where the folder images act differently?  Is this a firmware bug (i’m using the latest) as it wouldn’t surprise me as they can’t even get tv shows to sort correctly…

You probably need to check the file permissions. NFS permissions and ownership are handles COMPLETELY different than Samba.

I don’t think it is a permission issue.

I have full read/write opened up on the share.  Also the content info that is downloaded and saved under the NFS share for some recently added tv shows doesn’t show up on the folder level either but the images and content work fine as the others do.

I did just notice something about the folder image that did work.  I just noticed I also had a folder.jpg as well as a .jpg in that directory.  All my others are just .jpg.  Changing another one to folder.jpg has allowed it to work also but this is still no where near how it works under the samba share.

AFAIK. .jpg is meaningless. That’s “undefined.” There are folder.jpg and .jpg, but no function has ever been documented for .jpg files…

Ok well that is weird then…because all my images do work fine under the samba share.  Sometimes it would show the wrong image but it would still show something from the folder.

If that is the case, then how were any of my TV shows in seperate folders with files ever working?  I never put any images in there other then the auto downloaded content which would replicate the image up to the folder level.  The names on the those images are always <season, etc>.metathumb. 

metathumbs are handled differently than JPGs.  

Just to provide an update on this.  I did raise a support ticket about this and the response I received is that this is a known limitation with NFS.

“Thank you for your reply. After some research on the matter it seems to be a known limitation, it seems that for know there is no plan to include a fix
on a future firmware update, but you could post a suggestion on the WD Forums, in that way it can be consider and added to the fixes.”