Newbie - would like to understand more about old MyCloud device

I have a 2GB WDCloud that I bought in around 2016. I received several e-mails prior to April 2022 saying it would be inaccessible via the cloud though I don’t know how to find out which exact model it is, so this may not be the correct category.

I’ve been using it to provide storage on my home LAN as it has an ethernet cable that can plug into my home router. It works ok in this respect though I’m wondering if it is safe to use like this (this isn’t - yet - the main reason for this post). I have very little understanding of these things and up until recently I just thought of it as a fancy external hard disk.


  1. I’ve seen several threads on this forum where people talk about putting a new operating system on a MyCloud, its as if they are describing it as essentially a computer in its own right. Is this correct?

  2. Presumably this means there are all manner of ways of interacting with it “as a computer on the LAN”, rather than as just an HDD. What are these? (e.g. Is there any kind of linux terminal command I can send it? Are there resources on this forum that would help me get started with all this? Other ideas: ssh into it - how?, hookup a keyboard, mouse [how, via the USB port?] - hook up a display - how?)

Many thanks for any ideas.

[** details:

  • I know there are several versions but I think this one is literally just called WD My Cloud. How would I get a more precise description?
  • I’m aware of the you-tube videos at but I presume from the video posting dates that these are all for the new versions and that no access instructions will be common to my device. They don’t physically look like mine.
  • I’m currently using it on a home network where I can access it from two PCs running linux Mint

The My Cloud is not like a traditional computer. Yes it uses an operating system, but that operating system has been customized by Western Digital. Yes others have tried to run alternate operating systems on their My Cloud’s, to varying degrees of success. Use the forum search to find the numerous past discussions on alternate firmware (mostly using Debain).

You can only send those Linux commands that the WD firmware supports. You should first start by reading the My Cloud user manual for your device to learn more about what the device is. See the Support link top of page. Next one can access the My Cloud at the firmware level by enabling SSH in the My Cloud Dashboard and using a SSH client (Putty, winSCP, etc.). To learn about Linux commands or SSH use your favorite internet search engine to begin your education about what they are and how to use them. Then spend time using form search feature (magnifying glass icon top right) to search for the MANY past discussions on issuing various Linux commands to the My Cloud operating system.

There is a lot of past information here for you to learn from. There generally isn’t a one single “how-to” guide to answer all your questions due to the variety of My Cloud devices and their operating systems.

Hi Bennor,
Great, thank you very much for the plain English answer at newbie level. Just making the distinction that its a bespoke computer, not just a hard disk, has helped a great deal. I’ve already started looking up linux commands and replacement operating systems to find my way around.

I have another question. There is a folder called WD Smartware and I presume that the reason for the drive’s continual activity (all the time, even if I’m not running a backup ) is that Smartware is set to blindly attempt to backup items from computers on the LAN. I really don’t need it, or the folders at all, as I have my own linux rsync system working fine. I’m presuming from your answer, and that I only have linux PCs on my LAN, that Smartware is something that runs on the WDCloud’s own operating system rather than on a Windows PC/Mac on the Lan.

Question: How can I disable this software?

  • From what I see on this forum that “pausing” WDSmartware is something that folks talk about but I haven’t yet found out how to do.
  • I’ve also found broken links to relating to removing the software completely.
  • I’ve looked throughout the units own internal web page (at least that’s what I think it is, the place where I can still set up shares and passwords) and there is no sign in “settings” or “firmware” or anywhere else relating to pausing Smartware.

Thanks again.

Smartware isn’t “running” on the single bay My Cloud rather it’s just a Share that the Smartware software, if one installed it to their computer, will save a backup to. If one has Goodsync or the former WD Sync program installed on their computer then that software may be continuously syncing files to or from a Share on the My Cloud. If you don’t want Smartware, just uninstall it from your computer(s) if installed.

There are various services on the My Cloud that keep it running and which prevent the hard drive from going into sleep mode. If you use the forum search feature and search for “sleep” you will find copious discussion on the long running inability of the My Cloud to sleep and various methods, including disabling various My Cloud services using SSH, to deal with that long running problem. In general a network attached storage (NAS) device like the My Cloud is designed to be running 24/7 so it is always accessible on the local network.

Hi Bennor

OK, great thank you, another good step forward.

Hopefully the last couple of basic questions about the MyCloud:

It also has a USB socket.
Q1. What is the USB port for? I think I’ve understood it isn’t for connecting the MyCloud to a PC as if it were an HDD; so if not that, what else?

I’ve been assuming it has some old fashioned windows-like filesystem. If so I’d like to reformat it with ext4 (i.e. obviously having moved my data elsewhere!) but don’t know how to go about it. In the mean time I can see that the WD Cloud internal web page allows the owner to add and remove user password access to folders on the drive.
Q2. Are there ways to reformat it without removing the capability to manage user-password-controlled folders on the drive? i.e. is the user-folder access (and basically all the functions on the internal web page and the WDCloud’s ability to operate on a LAN) a part of the firmware rather than being system software that resides somewhere on the drive?

Have you read the My Cloud User Manual for your device? It explains what the USB port is for, how to use it, and what formats on USB hard drives the My Cloud supports, and explains how to perform a Quick Restore or a Factory Restore that erases the user data on the My Cloud hard drive. See the Support link at the top of the page and drill down to your My Cloud device’s support page. The My Cloud User Manual is there to answer the basic questions about the device. Further the Knowledgebase link at the top of the page will take you to the Knowledgebase section where you can search for answers to your questions. And no, you cannot connect the USB port on the My Cloud to your computer as a way to access the My Cloud.

The first question: What do you want to do with the device?

The myclouds; at their core; are NAS units (network attached storage).

The primary usage case is to act as a File Server on you network. In other words, a place to put files that are accessible to every device on your network.

To be a good file server, there is a CPU and there is an operating system. True. There is no Graphics card or USB inputs. … . so no way to hookup a Mouse, Keyboard, or monitor. The intended way to access the device is through your home network. You can access the configuration of the device (the dashboard) from a web browser by entering the device name or IP address into the browser. You can access the files by using a file browser.

The base operating system is a custom linux version (Called OS3) WD is advocating a newer custom linux version (Called OS5). As such, the drives are ALREADY formatted as EXT4. All those emails you got are simply advertisements for the new OS. . .and an announcement that the cloud functions of the old OS supported by WD are now gone. The devices will run just fine on the old OS’s. I have several OS3 NAS boxes. I had one migrated to OS5. I hacked it and rolled it back to OS3 for personal reasons.

The USB ports on these drives, as Bennor noted; ARE NOT general I/O ports. They are FOR USB HDD’s ONLY. They allow for budget expansion of the NAS beyond the space on the internal HDD’s. You CANNOT access the NAS through these ports. You can only access the devices via computers on your home network.

Oh, and as Bennor suggests. . . . .RTFM. You can find one somewhere on the support website.

A few moments of digging found these. (Just ignore anything involving internet) (there are two flavors of MyCloud; Gen 1 and Gen2)

My Cloud Personal Storage User Manual (

My Cloud Personal Storage User Manual (

Hi Bennor and NAS_user
Thank you both for your replies and especially for the links to the manuals. I had wondered what OS3 was and whether it applied to my device, that is really helpful thank you, as is the ext4 confirmation and the explanation regarding the USB-port.

You’ll be glad to hear I’ve got no more ill-informed questions, for the moment.

As an aside, just by way of explanation, I have no user manual from when I bought it (in the UK, it may even have just come with a quickstart leaflet) and, please forgive the rash assumption, but it never occurred to me that the firmware number accessed within the internal web page would be the clue that enabled one to match the device to an online user manual. Its a very logical system, with hindsight.

Lastly: I cannot access the support, downloads and knowledge base links:
Each of them comes up with an error picture as below (cropped to remove my IP) and despite that it says “please try again” I get the same response at all times of day. I’ve also tried the “Contact WD” link at the foot of the page to see if that would lead to a webmaster that I could report the error to but that has the same error.

I also tried checking the link provided by NAS_User to see if might be helpful and, low and behold, it was redirected to a comletely different website from which I was able to navigate to what “looks like” the right product page: