New Windows 10, Discovery software locks computer during install

For the last two days I’ve been trying to install WD Discovery with no luck. The result is always the same, software installs to 45% then hard drive, mouse and keyboard lock up, requiring a hard reboot I’ve tried all recommendations I could find here and elsewhere. I have two Windows 7 machines and they can access the drives, no problem. I’ve tried all available Discovery versions and I’m tired of this, As windows users know 7 will no longer be supported after Jan. 14, thus the start of using Windows 10.
Any new ideas or recommendations?
Thanks in advance.

1 Like

Well looks like all I got for the question I posted was a like and thanks for that. WD has offered no opinion on my issue and that was a disappointing. Looks to me like WD is backing away from the MyCloud platform all together. Shame but I’ve chosen to move on from this.
I purchased a NetGear RN424 Ready NAS desktop storage system and you know what, it works!
See you MyCloud, I’ve moved on.