New WDTV Live SMP does's see shares, but old WDTV Live does


I just bought a new WDTV Live, cause I heard there was a new version out that I could control with an app for my iPhone and that it did some new some (like streaming from Slingbox). Well, I do all my videos over a file share from my Windows Home Server (WHS v1), which has mostly worked ok with the older box. (I would occasionally not see the server, but mostly worked ok.)

I just bought the new one, and updated it to the latest firmare (1.9.10). It occasionally sees the other computers on my network (WHS server, desktop, and laptop), but can’t connect to them, and after showing them once, they fall off the list and I just get the perpetual, orange, spinning, arrow. In fact, if I leave it long enough, the box can lock up and I have to pull the power cable to reset it. I know my computers are set up right, cause my old box still works; just not the new one.

Does the new one see Windows shares at all? From all the posts I’ve seen, it doesn’t and never has, even with old firmware. People talk about the new one taking master browser status, and I guess that messes up it’s ability to see other computer’s shares.

Thanks for the help!

My SMP sees any Windows 7 shares as long as it’s in the same workgroup.

jking1024 wrote:


Does the new one see Windows shares at all? From all the posts I’ve seen, it doesn’t and never has, even with old firmware. People talk about the new one taking master browser status, and I guess that messes up it’s ability to see other computer’s shares.

It’s working fine for me…  I have five NAS devices, one Windows 7 box, and one Windows XP box on my network.

Both my Hubs and my SMP have no problems finding the shares.

Well, I would love to know how you all got it to work. I only see my two computers for about 1/2 a second, when I first turn on the SMP, and then ever again. They are all on the same workgroup. In contrast, my v2 Live sees the computers all the time, and it is NOT on their work group (It’s on “Workgroup” and the computers are on “Yggdrasill”).

From all the complaints, I’m a bit surprised anyone has Windows shares working. And you’d think WD would have flawless access to shares, but now, since Windows has been around for years and WD been accessing them for years, and the v2 box worked.

The v3 SMP is a pretty paperweight for me. I guess I’m going to have to send it back. Maybe I’ll wait for some company to have good support for 10-bit video and Amazon Instant Video.

well, network shares on WD SMP is problematic… maybe the network code is just plain afwul

this is my current problems,

  • it sees my windows shares, but sometimes its dissapeared… movie stop, freeze then suddenly no shares!!! just disconnected randomly… (sometimes within 5 mnt, 10 mnt or 20 mnt)

  • i have good signal/bandwidth, same workgroup, static ip adress, restarting the device wont help and resetting to factory default is also useless! still disconnect!

  • … and alos those WORKGROUP names workaround is also dont work, still disconnect! what happen WD??

  • to make the matter worse it, mp4 playback is problematic too! its freezing after a few second of playback WHEN PLAYED OVER NETWORK/WIRELESS (it played just FINE when played over local flashdisk) and FOR GOD SAKE it’s just SMALL TINY BITRATE MP4s !! and STRANGELY it’s played just FINE on MKV (same files/same sizes/same codec/same setting/in other words i JUST re-MUX it)

just fix it wd ! dont you test your software and device wireless capability on your lab??

*IT* just FINE when played LOCALLY! ANY FILE! HIGH OR LOW BITRATE! JUST fix the network/wireless problems…

It seems to have alot of problems on the network side by the amount of posts alone in regards to this and playback of avi files. Mine even likes to ask me for a phantom password and username on occasion

I did (finially) get it to see my shares, but once (somehow) it lost / forgot them, in the middle of browsing the directories. I was able to reconnect and go on. So yeah, there are still some issues with the share networking, but I guess it mostly works.

Last night was one of the most frustrating experiences I’ve ever had with this device (and that’s saying something).

The SMP would not see a Windows 7 share.  No matter how many times I looked.

So I left it powered up while I spent the next hour playing videos off the same share from six other devices:  Mac, XP, Win7 laptop, Raspberry Pi and two Android phones.

The SMP was hard-wired into the same network switch as the machine with the shares.  I tried wireless too. The SMP could see the internet fine (Neflix works great) so there was no connection problem.  Why couldn’t it see the share?  Is cold-booting it four times not enough?  Should I have sacrificed a goat?

Every device I own can instantly see this Windows share and browse it and load files from it and play high-bandwidth videos from it.  Every device except the SMP.

I hate this thing. 

1 Like

Try using a static IP.

If set on dynamic, EVERY time it starts and IP changes it does NOT reconnect, meaning shares are “unavailable”.

If that fails and device loses shares again, do a “Automatic” in the Network options.

I found sometimes that even if the “Test” was all three green (internet working) no PC shares were available.

Some say it has something to do with SAMBA. 


I have this problem too and it’s riduculous that it’s gone on so long.  I’m stuck at v1.04 because I need to stream from my Windows server.

Obviously something changed after v1.04 that broke Windows shares (in some scenario’s at least).

I’m starting to think conspiracy theory (like someone doesn’t want us streaming), it’s just unfathomable how terrible the firmware on this product is!

Is anyone from WD on this forum?  Are you reporting these multitude of ongoing problems to your management?  You’re killing the WD brand with this unfinished product.

The problem happened again yesterday.  The last time it happened I had to reset the device to factory defaults. This time a cold reboot fixed it. 

When I bought this… product… I expected that it might have some issues playing videos, but that the “bread and butter” features like playing from network shares would be solid.

The opposite is true.  It’s rare that this thing fails to play a video.  But things like SMB are barely functional!  

My $35 Raspberry Pi running XBMC does SMB perfectly.  It’s even fast.  AND IT’S ALPHA GRADE SOFTWARE.

The mind boggles.  I feel like such a ■■■■■■ buying this thing.

1 Like

At this point it seems OBVIOUS that WD is BREAKING non-streaming features (like SMB/shares).

Could Netflix and other streamers be paying them to do this? (lame attempt to force us to use pay services).

This failed product boggles the mind, what else could it be???

I pretty much gave up on trying to access the PC/SMP. I haev to copy my videos to a USB drive. Lame, but not much else I can do. 

I have the same issue, no connection to samba, Win7 shares or NFS.

This box have the network capability of a handheld radio, and it got onto the 1st place in a german news magazine! o0

Well i guess the best it get from me is a bad review after i send it back to amazon next week…

Win 7 SMB shares are working just fine here.