New wd passport essential stopped working


#1

I bought a 320gb WD Passport Essential last Monday, and it was working just fine until Thursday.  It just wasn’t recognized by my Mac anymore. I’ve tried unplugging and plugging it back and even restarted my Macbook, but still it won’t work. The light is on, but it can’t be seen by my Macbook. Please help! I’ve tried calling tech support already, but apparent;y Singapore is on public holiday today.

Please please help. Bought this from a store that’s far from my place, so it would be an effort to go back there.  Thanks!


#2

That may be the loose connection on the USB cable from the drive.

Plug the WD external drive to your computer.

Try re-seat the USB cable from the drive end.

It may be a little tough, but

Slowly pull it out, then re-plug it back.

Wait a little while for it to be recognized.

The LED light should come on and start blinking.

The drive should be working.

If not,

you might have to take it back to the store and exchange it.

If yes, great.


#3

Thanks! I tried your suggestion and the LED light did come on and started blinking, but it’s still not being recognized. I think it’s time to take it back to the store. I just hope that they’d be able to recover the personal files I have in there and transfer it to the new drive.


#4

The same thing is happening to me, however the led light is on, but not blinking and I am fricking out! All my working files are there and I don’t know if there is a way to recover therm!

When I open finder, it only recognizes WD smartware (and the icon of a cd) but the external drive, doesn’t appear. What can I do?


#5

The exact same thing is happening to me, i hope i can find a way to rectify it or recover my files, not happy. : (