New WD Blue SSDs barely work

Hello, everyone!

I have two nearly identical desktop PCs (different PSUs and graphics cards, everything else is the same), and I just bought two identical internal WD Blue SSDs 1 TB (SATA), one for each computer. The problem is exactly the same on both machines for both SSDs.

Intel Core i5-4670 3.4, 32 RAM, Asus Vanguard B85 motherboard
KINGSTON SSD 60 GB (system), WD Blue HDD 1 TB (works perfectly), WD Blue SSD 1 TB
Windows 10 Pro 22H2 x64

The disk works well right after formatting or rebooting. But in a few minutes, the writing/reading speed drops to just a few KB/sec. It can get back to life for a minute or two, but eventually stops forever at zero. Sometimes SSD gets disconnected and comes back only after restart, sometimes it stays connected for a long time. If I format the SSD or restart the PC, the disk works fine again for a few minutes, but then the problem returns.

WD Dashboard ( doesn’t see the SSD at all, only my WD HDD, so I can’t update firmware.
But everything else sees the disk: BIOS, Device Manager, and Disk Management. Intel Rapid Storage and CrystalDiskInfo utilities see it as well and show no problem.

I set the system to never turn off hard disks (advanced power settings). I also tried using other SATA ports (including the one that works perfectly with HDD), switching to another power cable, changing the SATA cable, and enabling Hot Plug in BIOS. No difference.

As I said, the problem is the same on both machines and for both SSDs, so I don’t think there is something wrong with the disks, rather with the system, software, or settings. Anyway, what should I do? What tests can I run?
Why doesn’t WD Dashboard see the disk on both PCs? Updating firmware is where I should start I guess, but I can’t do it without the Dashboard.

I will appreciate any help, thanks in advance

Hi @ked,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Yes, I have, the support team was very helpful. It turned out, I just bought fake SSDs