New WD Black hd: "Windows setup cannot configure Windows to run on this computer's hardware"

So my hard drive crashed in my 4 year old Dell Latitude E6520 and i got a new WD Black 750 gb Model: WD7500BPKX to replace it.

  • I have the backup Windows 7 Pro cd and i tried to install it and after a long process where it looks like it is installing it fine and it restarts i get that message (“Windows setup cannot configure Windows to run on this computer’s hardware”).
  • I’ve tried going back multiple times and either repairing the version already installed or installing a new version of windows off the same CD, but it has not installed correctly and when i try the repair option it says “Startup repair could not detect a problem” (there are also now 4 different versions of Windows 7 that i get to choose from, even after formatting the drive, but none of them will be repaired).
  • I ran diagnostics of the F12 boot options screen and got an error on the hard drive (i believe this was 2000-0142, but i dont know for sure because i’m not getting that error anymore).
  • I formatted the drive and tried again, and got the same message about windows setup not able to configure it on this hardware.
  • I re-ran the diagnostics again and got no errors on the hard drive (i did still get one on my battery: PSA V4206 2000-0132 Battery: The battery is reaching the end of its useful life. - this couldn’t be causing the problem, right?)

Any ideas on how to get it working? is the new hard drive bad? or is there some other issue in my computer that just makes it seem like the hard drive?

thanks in advance for your help!

ok, so after talking with an it guy, googling a bunch and not getting many solutions, i found this: https://support.microsoft.com/en-us/kb/2466753. I followed the instructions, and downloaded the latest driver for the 64 bit thing and loaded it before installing windows and after a little hiccup that i left the usb drive in causing it to say that the partitions were invalid, it loaded fine and seems to be working well. thought i’d post this as the solution in case anybody else has the same problem.

1 Like

Hi there,

Please check on the following link, this might help you out on resolving this or verifiying the cause of it:
https://support.microsoft.com/en-us/kb/2466753

Hope this helps.

Ha! great timing. I just posted that this is the solution. Thanks!