New WD 10TB Drive Not Recognized by NAS


#1

I just purchased 4 WD 10TB HDD to expand my current NAS which now has 4 WD 8TB drives. 3 of the drives install properly. However the fourth is not recognized by my NAS (Asustor AS3104T). When I plug that drive into a separate Hard Drive Docking Station, however, it is recognized by my PC and can be formatted and used, etc. One thing that I noticed about this particular drive is that there is actually a difference in the way the drive looks on the side that plugs into the NAS. The actual normal drive connections are the same…but the part of the drive to the right is different. I will upload a picture so you can see what I mean. Any ideas about this as well as the “different” look of this drive? Thanks for any help.


#2

Did you check the list of compatible drives?

https://www.asustor.com/service/hd?series_id=&id=hd&brand_id=4&type_id=2&size=10%20TB&class=


#3

Thanks for your response. Yes, my HDDs are deemed compatible by Asustor. And of course in this case 3 of them work fine, only the fourth one is a problem.


#4

I have a cheap little Shuttle KD20 2 bay. But I noticed when I put drives in it the 1st time it didn’t see one of them. I reversed their positions and it worked. I don’t know why that made a difference but it did.