New User My Passport Ultra 2TB Backed up volume

How do I change a backed up volume to retrieve files from My Passport Ultra and not the PC?



I’m not understanding your question clearly. Can you share more information about your case.


Thank you for your reply. This is my first WD product. I am trying to retrieve my files. You have to choose a backed up volume to choose from, which I did. Then after I clicked on next I had to choose from two other options. The choices were not listed as pick from PC or Passport Ultra but worded differently. I forgot to save the screenshot. The arrow points toward the PC and not the Passport Ultra after the retrieval was completed. I wanted to retrieve the files from the Passport Ultra. How would I do that?

I ran into a new problem when I tried to “Safely Remove Hardware and Eject Media”. The first time I used the Passport Ultra I just saved my files and did not retrieve them (the hardware was removed safely and ejected.) When I tried to do the same this time, “Safely Remove Hardware and Eject Media”, I get the following message.

I have closed all of the programs I was using and then get this message:

I have no idea what program the device is still using.

This is only the second time I have used the Passport Ultra. I can’t turn off my PC until the Passport Ultra has been removed safely and ejected.

Thank you for helping.

I am new also, just bought it yesterday. Had the same issue, but, just waited, and it sorted itself out. I still have no idea what program it is talking about… Would be curious to know. I am running windows 10, 64 GB.
Maybe something to do with Win10?
Thanks, CD


Thanks CD. I am running windows 7. I am still waiting for it to sort itself out. I have a reboot that needs to be done for an update for a program that showed up this morning. I have postponed it. I don’t know how long I can keep postponing the reboot. If I haven’t been able to safely remove the Passport Ultra I don’t know what will happen to my data or what damage will be caused to the device should there be a power outage (had several power interruptions from a storm recently but it was before I started to retrieve my files) or if there is an auto reboot for an update.