New Thread. WD TV Live doesn't recognize my Elements


#1

Hi! guys I choose a WD TV live and WD elements 1.5TB

The Wd TV live does nto detect its own WD Hard drive? strange

Does nybody know a fix

Firmware is updated to 1.02.21

However before update it was working but now it does not so anyway to downgrade the system

vinod


#2

Have you tried resetting to factory defaults?

Hit the reset button on the side (use a  paperclip).

Let it reboot.

In Setup, select Reset to Factory Defaults.

Let it reboot.

Once it’s rebooted, put it in standby and pull the power cord.  Leave it for a few minutes.

Put the power cord back in, unit will auto power on.

That’s as fresh and default as it gets.  

If it still misbehaves, follow the downgrade advice here:

http://community.wdc.com/t5/Firmware/downgrading-firmware/td-p/18058

Good luck!


#3

I have exactly the same setup: A WD TV Live with firmware v 1.02.21 and a WD Elements 1.5TB. And my WD TV Live doesnt detect the HD either. Unfortunately I bought the WD Elements a few days after the firmware-update, so I cant say if it has worked ever. I hope the next firmware update will fix this problem, meanwhile I use the HD as a network share via PC with the WD TV Live.


#4

Hi Guys,

Are you sure your drives are FAT32? Had the same problem with the Sony PS3.

Maybe worth a shot and hope it helps.

Rob


#5

Hi,

why the drive should be FAT32? Elements is shipped as NTFS as far as I know.

I just had the very same issue: firmware 1.02.21, new Elements desktop 2TB ordered last week, but the drive is not recognized at all. On the WD TV Live, the USB led gives no sign, no flashing, nothing.

Just posted a support request to WD, but before they could reply, I have found another forum with the “solution”:  downgrade to 1.01.17 (other versions may also work, not tested).  This is exactly what I did then … and… wow, it has worked immediately.

The funny thing is: WD has answered, the WD TV Live does only support external drives up to 1.5TB.  :dizzy_face:Not only WD did not tell it anywhere (or have you guys seen any official announcement of this), but it is obviously not true, as my 2TB Elements seems to work with firmware 1.01.17 just fine.  After teaching WD about the above, they just replied, OK, your input has been forwarded to the developers - obviously they want to close the case as “solved”. 

I am getting angry with customer service like this. 

Any comments welcome.

scsaba