New Release - WD My Cloud Firmware Release 3.03.02 (1/29/14)

Thanks again for trying to help.

I downloaded from the new firmware link for the previous version and tried to update my WDMyCloud 3T with the extracted file. My device put out an error message.

ERROR

“Device does not have enough space for an upgrade”

So it would appear I cannot roll back the firmware.  I hope this is not the case and will be contacting WD support on Monday.

Regards

CTB

I am just beginning to use My Cloud and have some questions.  1) Do updates automatically download?  Because of the instructions in your comments, I suppose it doesn’t.  2) How can I see exactly which files have uploaded to My Cloud?

I have been having trouble with my PC and I think the files are uploaded, but I would like to see them.  3) When downloading back to the PC, can I pick and choose which files to download?  And, finally, exactly how do I access My Cloud from my laptop?

I really appreciate any info you can give me or point me to.  I usually don’t have much trouble when I get new things, but this is really confusing me.

Thanks again for your patienct, understanding and help.

placebow

Well, it’s 3:56pm and no call from WD Level 2 support. I just checked my case number and there is no logging, from support, of any sort so I don’t know what to do.

In my response email to [Deleted], sent on Feb. 5, 2014, I gave him my cell telephone number to call and I have not heard a thing.

*************************

Update:

I just called WD Support to see what was going on … I was told that they will call me back. I will post what happens.

*************************

Update #2:

I have waited another 2 hours

It’s now 6:09pm and never heard a word from Wd Support even after I called them and I was told they would call back. Needless to say, I am somewhat disappointed in all this! :angry:

placebow;

WD My Cloud™ Personal Cloud Storage User Manual:

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf

All of your questions are covered in detail, enjoy!

Hi Guys

I have found a workaround for my problem with the new firmware of mapping shares to Windows Vista drive letters.

With the new firmware release Windows Vista cannot see any Share on my WDMyCloud NAS without the Share being Public.  Once made Public you still need of course the correct User name and Password to read or write to the Share.

Under the last firmware Windows could see all the Shares on the NAS as a network drive and could access if you had at least Read access and were the correct User with correct password.  Or if you were the Admin account with correct access and password.

The downside/problem that needs to be fixed is:   By me making the Shares, I need to manage, Public all my Users offsite using the WD My Cloud Mobile App or WD My Cloud Desktop App can see and read the Public Shares.  As I have several offsite Users I don’t want them seeing everything.   This makes the device not fit for purpose.

Being able to see Shares as network drives under Windows, needs to be put back to how it used to work under the previous release where from my usage all worked correctly.  Of course Windows should only be able to access if you have the correct User and Password.   At the moment you cannot see the network drive to be able to access it.

Hope this makes sense and WD are reading these forums.

CTB

PS I have also tested on my Android Samsung Galaxy S4 and have exactly the same issues as Windows Vista.  Have also tested on iPad2 IOS7 with Goodreader and FileBrowser , they all cannot see when on the same network my NAS Shares as LAN drives unless they are made Public.  They used to be able to see then but not access unless they had the correct access rights.

PSS I have tried twice to roll back the Firmware to a previous version with my WDMyCloud not allowing me to do so.  This is equally a big issue that needs to be fixed,  Can WD post all versions of Firmware releases on their website and test that we users can download and install to upgrade(which appears to work) and downgrade when necessary.  My automatic update of Firmware is now permanently OFF.

 --------------------------------

Update 11 Feb 2014

Talked to WD Support and have solved my problems.

The firmware update appears to have corrupted my User Passwords.  

I had to do the following through the WD My Cloud Dashboard.

1 Refresh all User Passwords.  By selecting each User then edit by the side of password and entering a new  password.

2 Switch off the Public access for each User I had been forced to give to my Shares

3 Reinstate the access I wanted each User to have to each Share i.e. Read, Read/Write etc.

Then in Windows Vista I could Map Network Drives for each Share on the WDMyCLoud NAS as I had before.

Note:  Some of the shares would not appear straight away.  I had to go back to the Dashboard make them Public then switch Public off and reinstate the Access rights again for each user.  After several attempts it worked.

WD Support also requested I make the WDMyCloud IP address static, which I did via my router. Apparently this makes the device more stable.

Also to roll back Firmware you need to make the file a higher number as SectionGZ suggested.

WD Support were very knowledgeable and helpful.

@CTB_WD,

We have the same firmware issues on the Seagate NAS’es as to what you are describing. The work around there was to rename the “Roll Back” firmware to a progressive number higher than the Firmware you are on.

Example:

Original Rollback Firmware Name:

03.03.01-156

 

Firmware you arre presently on:

03.03.02.165

Rename 03.03.01-156 to  03.03.02.166 and install

 

I am not saying this will work on the MyCloud nor do I know if this would mess anything up more than it already is. But this method we had to use on the Seagate NAS’es and it worked.

 

Just a thought.

Hi,

 Just wanted to report a, so far, succsessfull firmware update. Took about 20 minutes overall. So far everything looks good.

 I will certainly post if anything goes astray.

Level 2 Support and I finally made connection and I am happy to report that my MyCloud is working perfectly. The Gentleman from Support was excellent in every issue I had. I still have some tests to run, but I feel very confident that the outcome will be positive.

One of the big things I noticed was it seems that a 20 second reset was needed for the firmware to make it’s final adjustments or there was some lagging data from the previous firmware that the reset set correctly.

A Big Thank You goes to level 2 Support. :smileyvery-happy:

My drive is working pretty well after the firmware update with one excpetion. I added a usb My Book to use to make the safepoint backups. I hadn’t done one prior to the update. I let the safepoint run for about 30 hours and finally cancelled it after it only had 56% done in that amount of time. I only had about 90GB stored that I was trying to backup. While the backup was running, I couldn’t really use the drive (too slow to respond if at all). Anybody been able to produce a safepoint to an external drive? How long did it take? I assume after the initial safepoint updating won’t take that long. I just needed to use the drive and couldn’t wait a week to get the safepoint done.

Hello OGilley,

I see you have experienced also the slow Safepoint back up. Let me see if I can advise you about trying something.

Switch off Media Scan, Switch off Itunes Server, Switch off FTP, Also switch off on every share with Media Scan. Then let the My Cloud Calm down. You can hear this when it does not rattle anymore so much.

Then delete your Partition of the USB Harddisk on a computer and Create a New One and then Format it either with NTFS or EXT3. Then update the MBR if it is a 2 TB and if it is bigger than than that, Update the GPT. You do this on a computer with a Partition Manager. Look around which is suitable. They all can do this. Paragon is onehttp:// www.paragon-software.com/home/pm-express/ , AOMEI is one http://www.aomeitech.com/aomei-partition-assistant.html, EaseUS is onehttp:// www.easeus.com/partition-manager/ .

Then hook the USB drive up to the WDMC and do a Safepoint again, yes, it is going to take a while, but when it is done, the next time it will be easier. Do the Safepoint overnight and let it finish. Let me know how you are getting on.

Level 2 support asked that I try to make a Safepoint for which I completed last night and it was successful. I made a Safepoint to another NAS over the network. I backed up 270GB in ~6 hours, Although not blazingly fast but a lot better than copying everything from the MyCloud to the other NAS through Windows. It was a total mixture of large files ( 500MB to 1GB ) and many, many small files ( 500KB to 10MB ). The small files were the killer as far as speed from what I did observe.

@ SectorGZ,

Yup, Small files are the bottleneck on the WDMC. But usually it is always when writing to any normal HDD, except highspeed SDD’s it goes much faster.  That is why you see the big players such as Synology and Qnap having an option to put Cache SDD in their NAS’s and it will go much better as well the application of Link Aggregation, 2-4 LAN Connections on one device. Some of the The EX4 and WD Sentinels do have 2 LAN’s as well, which can make a big difference and as long there is Cache memory avaiable.

…what a joke

Since I updated I have gotten extremely slow and unreliable file transfers. It literally takes it 5 minutes to load my root folders. I cannot even use this drive because of it anymore. I have tried resetting and everything. Has anyone else experienced this? 

1 Like

When i check my lastest version, it says: MyBookLive 02.43.03-022 : Core F/W

When i click on ‘check for update’, it says ‘my firmware is uptodate’. Why don’t it find the firmware automatically?

This is MyCloud forum.

Has anything been done to correct the “unreachable” unit issue? My 3TB MyCloud unit disconnects from my network every day and can only be brought back online by disonnecting power and forcing a reboot. My other “identical” unit is on the same current level of firmware (03.03.02-165) and attached to the same switch as the failing unit. Suggest we are dealing with a hardware difference, not a software issue.

I would post your issue in thread http://community.wd.com/t5/WD-My-Cloud/More-Info-Needed-The-WD-My-Cloud-is-Disconnecting-from-the/td-p/674937

I am also experiencing at least 3 errors.

Share function failed. (400099)

and

Media server database internal server error. (400162)

Also date modified on pictures on older pics dates correctly from the exif data.

The newer ones with gps data uses what appears to be GMT time zone once copied to the NAS (LAN) instead of -5 Eastern as the NAS is setup.  

After creating maybe 8 users I got a share error.  This is after being setup, drive half full of backups, restoring & wiping data to try and correct shares that didn’t show up in the share list but were stil created after failing on creating a user.

But, thinking back, I believe the VERY first error was when I tried to create a new share with media sharing enabled. 

I cannot rebuild the media database after corrupting with shares created without users not showing up in wd mycloud share list.I’ve done the quick and the system only several times.  I’m now doing a full restore which I don’t see why should make a difference.  I am VERY dissapointed in the quality of sotware from such a previously well respected company.  If the full restore doesn’t fix the problem, I’m returining it if firmware isn’t released soon.  

We just released a new firmware update for the WD My Cloud.  This thread is now closed.