New Release - Smartware, Windows Version 1.3.0.16 and Mac Version 1.2.2.5 (5/20/10)


#1

WD is happy to announce its newest SmartWare update for both Windows and Mac computers.  You can now go to the  SmartWare Download page, and pick your drive and OS to download your update. 


#2

Thank you very much. The updater did not work and removed the software folder after installation. I had to install the old software again (1.2.0.8). I believe you are aware how useless this version is.

Please fix this soon so I can update the software.

Furthermore it would be a good idea to offer the possibility of downloading a previous update.

WW100

The Netherlands


#3

In my Windows Vista 64bit it installed ok, but the backup is no longer working.

I’ve erased all backup data in my MyBook Essential 2TB but SmartWare is still not working anymore. It does not show ‘categorizing your files’ anymore and ignores the  ‘start backup’ command.

I have another system with Windows 7 64bit and it installed fine, but is no longer backing up the data as my Vista system.


#4

I got the same thing as WW100.

Update says it’s finished but the smartware is gone, restarted my machine, but still gone…

had to install old version

tried this on my windows vista 32bit and on my windows 7 32bit, i am using the mybook essential

hope this gets fixed soon…


#5

Hello, same problem here. I have version 1.2.0.8 in VCD which is the only I can get to work. I tried everything, for hours, to update to version 1.3.0.16 but always without success. Everything apparently goes well, but at the end it all just disappears. I have a MyPassport Essential SE, in Windows Vista 32.

I hope WD can support us soon.


#6

Like I just said in another thread, you need to make sure you have all your Windows and .NET 3.5 installed before updating to the newest version of SmartWare.

http://www.microsoft.com/Net/Download.aspx


#7

Complete BS


#8

IT IS ON MY W& and your software still ■■■■■ - you are wasting my time


#9

Same problem here with windows 7 ultimate / 64 bits

I FOLLOW ALL THE SUGGESTIONS AND ANYONE WORKS TO UPDATE

Tks


#10

The update not work for me too.

Actually Version: 1.2.0.8 (Default of my WD). I purchased it on Saturday.

Waiting for one update.