New Release - My Cloud Firmware Versions 2.31.149 (10/19/18)


#1

WD is happy to announce the release of My Cloud Firmware 2.31.149 for manual download at https://support.wdc.com for the following My Cloud products.

· My Cloud
· My Cloud Mirror Gen2
· My Cloud EX2 Ultra
· My Cloud EX2100
· My Cloud EX4100
· My Cloud DL2100
· My Cloud DL4100
· My Cloud PR2100
· My Cloud PR4100

What’s new?

Security Fixes

• Resolved multiple command injection vulnerabilities including CVE-2016-10108 and CVE 2016-10107.
• Resolved multiple cross site request forgery (CSRF) vulnerabilities.
• Resolved a Linux kernel Dirty Cow vulnerability (CVE-2016-5195).
• Resolved multiple denial-of-service vulnerabilities.
• Improved security by disabling SSH shadow information.
• Resolved a buffer overflow issue that could lead to unauthenticated access.
• Resolved a click-jacking vulnerability in the web interface.
• Resolved multiple security issues in the Webfile viewer on-device app.
• Improved the security of volume mount options.
• Resolved multiple security issues in the EULA onboarding flow.
• Resolved leakage of debug messages in the web interface.
• Improved credential handling for the remote MyCloud-to-MyCloud backup feature.
• Improved credential handling for upload-logs-to-support option.

Components Updated

• Apache -v2.4.34
• PHP -v5.4.45
• OpenSSH -v7.5p1
• OpenSSL -v1.0.1u
• libupnp -v1.6.25 (CVE-2012-5958)
• jQuery -v3.3.1 (CVE-2010-5312)

Other Bug Fixes

• Resolved high CPU utilization with ufraw-batch process.
• Improved remote host port handling


#2

#3

#4

#5

An updated kernel version would be nice…


#6

Any plans to provide such throughout security fixes for the MyCloud Mirror 1st gen (2.11.x FW) as well?

Those 2.11.x FW version is e.g. still vulnerable for the libupnp vulnerability posted few years ago:


New firmware 2.31.149 for Cloud EX2?
#7

WD My Cloud App doesn’t connect with the cloud anymore ? App find the device and show correct IP adress, but then get an error after update for 2.31.149ver.


#8

@blk Support questions probably doesn’t belong into a firmware release thread.


#9

I have the same problem after update to 2.31.149 firmware version.
My Cloud App (windows version) does not connect anymore to the NAS from remote.
PLAESE SOMEONE CAN HELP ME ???!!!
Thank you in advance