New Passport Essential - major problems

OK, just received a 250GB My Passport Essential. 

Connected to my PC which recognised the new hardware and launched a menu. I chose to install the ‘Lock’ software and was able to enter a password to secure the device.

However, It shows as two drives on my machine: A CD Drive called WD Unlocker and another Drive which tells me it needs to be formatted. Except, it won’t format. I have tried the WD formatting tool and it won’t work.

Also, when I run the unlocker.exe it won’t accept the password and the ‘password hint’ is just random gibberish symbols.

However, in my notification area there is somethign called WD Smartware and if I open that and click on the disk icon and then enter the same password as mentioned above, it  unlocks!!

Still can’t use it though as it doesn’t format.

So, any ideas how to format it and also, how do I stop it showing as two drives? I don’t want to see the WD Unlocker CD Drive, I just want one drive letter with a formatted hard drive which is password protected.

Regretting buying this P.O.S now to be honest.

Uninstall WD smartware software. Its bloatware and a resource hog, not to mention a problem… You dont need it… That should fix your issues.

If you uninstall the Smartware make sure you remove the password first as a saftey precaution. I don’t know if the Smartware is necessary to use password or not.