New n900 router : can't access my external WD USB storage

H all, I’ve just got my N900. The wi fi works great. I have attached to the unit  a WD Elements 3 TB USB 2.0 External Hard Drive.

From the configuraiton panel the unit is there, configured as you can see form the attached picture.

The problem is that i cannot see it when connected on the wifi from my Mac laptop (with Lion).

Cn anyone help me?


the firmware i have is Version 1.02.02

Ok i’ve updatet to the last firmware 1.05.12

Still no way to see the external drive in my Finder.

Still the external dreiv is properly recognized by the router. See screenshot attached.

I’ve also tried to change the access form public through username and password. Nothing chagned: no way to see the drive on my MacBookPro.

Are you able to see the drive from a different computer in the network?

You have to map the drive

Goto finder, at the top click go and then “connect to server”

type in smb://

click connect

then it should ask for your login, just click connect

then it should show you your hard drive. just click on it and

it should show up in your finder

1 Like

Yup i had to map it…

Previously with another router i was able to see the disk directly.

But anyway it works now.


I had a similar issue, but noticed that on a reboot, the router did not see an already connected hard drive. I shut down the router, disconnected the usb cable, restarted the router fully, then connected the hard drive.  The router then recognized the device without issue.  Please test this to see if it is the case. If so, enter a case with WD so they can track this issue.


Digging up an old post. 

The solution given here works. If you map the hard drive it will show up. But that is really the worst thing you can dream of. On every single other router, my hard drives show up in OsX Lion and Mountain Lion without any mapping. So I do not have to find out the IP address of my device to access the storage. 

To make things clear, this works with the box provided by my ISP (called “FreeBox” here in France, which is a router coming with a 250Gb hard drive) ; with my LaCie NetworkStorage NAS (the NAS appeared itself in the sidebar ; double-clicking it shows the USB drives connected to it) and with my Apple AirPort Extreme (the hard drives hooked up even using a USB Hub did show up). 

With the N900 the USB storage has several problems, at least on a MAC : 

  • 1°) first problem : they do not show up in the side bar of the finder ; if you forget your routers IP address, good luck mounting it with the “mapping” procedure ! ; 

  • 2°) when it mounts, the name given to it is not accurate. Here’s an example. I have a hard drive that is called “BRD3”. If it’s mounted using the “mapping” procedure, it shows up as “WDC_WD30_EURS_63R8UY0_90”. Not really explicit. So if you have 2 hard drives hooked up, which one is the one you’re looking for ? Every other router I used (see above) did show the ACTUAL volumen name. Why the **bleep** can’t WD do the same ?

  • 3°) if you’re lucky, you’ll end up with the “mapping” procedure showing you 2 partitions (and not only one). One is about 206,4Mb large. But partitions over 2Tb will only show up depending on FW release. With any other router, this did not occur ! Why the **bleep** is this happening with the WD ?

  • 4°) if you use a USB Hub, you will not see both USB devices, but only one. Every othe router with USB built-in that I used was able to mount the 2 or more hard drives connected to it. Why the **bleep** can’t the WD N900 do the same ? 

All in all, I was really excited about the 7 Gigabit ports and 2 USB ports. But the latter has now proven to be useless. At least on a Mac. 

So I guess thsi should be advertised as MAC INCOMPATIBLE !

And by the way : it is not “multimedia over Samba” friendly neither. 

So what remains ? Nothing to me… The USB ports are useless. The SMB sharing works only with Windows (I should have suspected this when the hard drives did not show up on my Finder in OsX) and not with multimedia devices (like networked display or networked Blu-Ray players… YES, DLNA works, but it’s **bleep** !). The Gigabit Ethernet ports suffer from intolerable dropped frames when used. 

This will end up in it’s box or on eBay. But even on eBay, how can I sell this peice of **bleep** and still be able to look at myself in the mirror in the morning ? 


For me this worked perfectly the first time.

However, after taking the hard drive with me for a week, I want to remap the drive. When I try to connect it says "There was a problem connecting to the server “"”

Got any idea why this happens?