New MyBook Live 3TB - Ipad App "Device Offline"

Hi all

I bought a MyBook Live 3TB yesterday, and tried to set it up with my iPad 2.

I downloaded the app and followed the instructions on the dashboard.

I created a code, which I had to input on the iPad, though on the dashboard it says the code has yet still to be activated? Also when trying to connect from the iPad to MyBook, I receive a “Device Offline” error. I am trying to connect from the iPad to the MyBook on the SAME WiFi network.

The device is working fine, and I can conntact to MyBook using my PC on the same WiFi network.

Any ideas? Thanks guys.


Hi, in my case it took a while for the app to recognize the my book, but if the problem continues, try installing the app and creating a new code.


I have the same problem, I can’t access My Book Live with WD 2 Go on my home wireless network.

I am working with:

MyBookLive 02.32.06-006 : Core F/W

Router - Thompson TG784n

Ipad 3 - iOS 6.0.1 (10A523)

Toshiba laptop with windows Vista Home Premium SP2

Just bought the My Book Live 3 TB yesterday, connected to my router (for those in Portugal it’s the standard MEO router), accessed http://mybooklive from my mum’s laptop just fine, created a password, enabled automatic updates, created two mobile access codes and a web access account. So far so good, loved the interface.

The web access worked like a charm, I was able to open the shares in explorer, upload and download content. The problems began with the iPad… It took me a while to get WD 2 Go and WD photos on the iPad to work (had to create several new codes), but after rebooting everything it worked. Now WD Photos works, I can see some photos I put there to test and upload photos, but can’t access WD 2 Go, it ALWAYS says “Device is Offline - the device is not accessible” (in the portuguese version “Dispositivo offline - este dispositivo está inacessível; apenas arquivos locais estão disponíveis”).

Searched the forum for similar posts, but I’m not that savvy and most of the solutions seem for advanced users, but I found some which said a restore or a change of name could solve it. I did a Quick Factory Restore,  did everything again, didn’t work, changed the name and checked the rest, didn’t work. I am still in the same situation, computer local access and web access ok, WD Photos ok, WD 2 Go not working. Can someone help me?

I haven’t tried in another wireless network yet, but I bought it to access my files remotely when I’m travelling and I hoped I could watch videos using OPlayer HD or other similar player.

Alucardx23 wrote:

Hi, in my case it took a while for the app to recognize the my book, but if the problem continues, try installing the app and creating a new code.

For me either. After the last firmware update WD2go on iPhoone said driver is offline. I deleted the device in MBL, genereted a new code, introduced into WD2go on iPhone and… apparently nothing happened. Did the things above again and again, finally I gave up and … after about 1/2 hour… it worked (MBL showed that the device was connected).