New My Book Live 2TB with many Dashboard errors and can't access folders!

Hello everybody,

i just recieved my new My Book Live 2TB today, but I’m having so many problems:

First of all I had to change my home network, enabling DHCP server to find it! not so smart for that! 

In any case after find it, when i open the dashboard to change setting, it’s very very slow and doesn’t let me to change setting as always there is an error 3xxxx…

I can not even open the folders, under my network.

The firmware version is: 02.32.06-006 : Core F/W

I tried to do:

but no change.

I tried to downgrade with the version 023205-046, but it does not work, just say updating firmware and do nothing.

I can’t try to downgrade as below:

as i can’t open the MBL’s folder to copy the file.

in the dashboard first time there was an error about an unexpecting restart in 10 october 2012!!!

My router is an old one, DSL-G624T 10/100, but i don’t think that everything is its fault!

Please HELP!!! 


Are you able to test the drive with a different router? That will eliminate your suspicious on the router.

Also have you tried resetting the unit?

Hi and thank you for your reply.

I tried to connect it directly to my PC, and infact it’s very fast now and I have fast access to the folders.

So my router is the problem for the speed, but could it be something like a firewall on the router caused it?

I will try to check it with another router.

But there is still some error in the dashboard.

I can’t understand why I have a version of firmware 02.32.06-006-20121010 that doesn’t exist in the WD’s website!

I tried to downgrade it to the version 02.32.05-046-20120910, but got another error  31101 - Invalid firmware package.

Use WinSCP to SSH into the MBL and transfer the rootfs.img file to /DataVolume/Shares/Public. You should then be able to rollback the firmware following the downgrade guide.

Done!! thank you!

by changing my router too, now every thing is ok!