New MKV files stall media library compile

Just purchased Tom & Jerry: Golden Collection Volume 1 [Blu-ray] [US Import] from Amazon. All ripped to MKV using MakeMKV using the WDTV profile that I have been using to rip all my Blu-rays. This disc contains the first 37 MGM Hannah Barbera shorts in the original unadulterated un-pc format. Since copying these onto my NAS Movie folder the media library never stops compiling. If I remove them the library does eventually re-compile & once done only does a quick re-compile on restart.
Moving the files out of the media library they play fine using browse folders. Also play fine if I turn media library off and place them back into the NAS Movie folder.
Anyone have an idea what may be going on?

I highly recommend this T&J set and really looking forward to Vol 2. If you like T&J get this Blu-ray not the adulterated PC DVD version. Warner Bros have done a fantastic job of cleaning up the originals but there is still enough hair & scratches so you feel like you are back in Saturday morning cinema.


Hi, you can first check if you have the latest firmware version installed, if you already have it, you can select the option to clear the media library.

Paste the text output of Mediainfo to one of these files. I use MakeMKV all the time without any issues. FYI, all the WDTV profile does, is compressing PGS subs with zlib.

Thanks for the reply. Unfortunatly I have had to fly out to a job in Dubai for a couple of weeks so will post the media info when I get back. I’m not sure that the issue is with the files themselves though as they play fine the the SMP.

Just this compiling stuff is killing me.



I am running 1.15.10 fw.

I have not updated to 1.16 fw due to all the negative posts re this version.

1.15 has been working fine for me up until this rip.

I will try a media library clear when I get home in  acouple of weeks.

Many thanks


OK I feel a bit foolish.

Having been a way for a few weeks I eventually found some time to look into this when I got back.

Still could not get the media library to compile. Tried everything - clear Media Lib, reset SMP, added media Lib shares back in - and still no joy.

Figured I’d take a look at the NAS and pulled it out of the cupboard in my study and then the penny dropped.

Before I went away I did some technical tidying. The NAS used to be connected straight into my Zyxel router, but due to the sheer amount of network stuff I have in the study I had moved the NAS connection from the router into a new Netgear GS724 GBit switch. I remembered at that moment that I had tried moving the NAS once before onto one of my HP Procurve gig switches and this broke the media library.

I moved the NAS back onto the router and within minutes the media library had compiled.

Now I am able to enjoy T&J in all it’s Hanna Barbera / Fred Quimby glory.

I don’t know why the combination of NAS, SMP & gig switches breaks the media library but it is repeatable.

Disabling the Media Lib - I could still play content with the NAS connected to the gig switches.

So as the old adage goes - If it ain’t broke…

Lesson learned!