New HD failing already?

I recently bought a 2TB WD External Elements drive, model number: WD Ext HDD 1021, firmware number 2021

On the first day it arrived, I plugged it in, it was recognized it right away, the drivers installed, etc … it was “ready to use” On that same day, before doing anything else with it, I ran WD Data Lifeguard Diagnostics on it, the Quick Test (<30min), and the Extended test (~16 hours), both results were OK.

So I started copying files to it, I started with one large folder (>100gb), it took about 1.5 hours but it worked ok - I was able to access the copied files from the new HD just fine. I started copying a second folder (~90gb) and it got about halfway through… this is when I plugged my MP3 player in to charge it up, I did not transfer any files to or from the player (I don’t know why this even would effect it, since they use different USB ports far away from each other) Then i noticed a Windows error message (from the file transfer to the WD drive) saying “filename is too long” (not uncommon of course) so I clicked “skip” planning to fix them later.

This is when I noticed the folder on the WD drive was no longer open and it was no longer copying. When i realized it was not visible anywhere on the PC, I unplugged it, plugged it back in (both power and USB) and … nothing. After restarting the PC, it was recognized again, but then DLGDIAG did not see it as a physical drive, only as a logical drive (so I couldn’t run any more SMART tests to check it)

Eventually it did show up listed under physical drives in DLGDIAG (don’t know why, it was not there and the next minute it was), but now when I run a SMART test it tells me “Could not open SMART or port driver on drive 4!” Immediately after I usually get a message saying “Cable test failed! Please check the cables.” These came with the drive (brand new) and there is no physical damage I can see. Sometimes after clicking OK it gives me the message “Too many bad sectors detected.” which frankly scares me. My next step was to try and salvage the data I already copied to the WD drive, but no luck, now Windows Explorer does not even recognize the drive (neither does the Device Manager). 

What is going on with my new drive? Is it failing already on the second day? Are my cables defective? But then what about the “Too many bad sectors detected” message?

I can post my results from the first test (the test which said everything was fine) if it helps, but it doesn’t say much besides “PASS”. I have not gotten it to run another test since.


Ok i just saw the FAQ, I guess I will have to work through that first :cry: but this is incredibly frustrating since this drive is literally brand new. 

Ok update … I believe this drive is 100% dead now, after going through the checklist:

1- does not spin up when plugged directly into the wall

2- replaced power adaptor … still does not spin up

So after taking 16+ hours to test it according to WD directions … and getting the OK from your software to back up my files… it immediately fails taking over 100gb of my data with it.

Unless someone has some great ideas, it looks like I will be returning this junker :cry:

Yup sorry, sounds like a bad hard drive.