New frimware 04.04.01-112

My device started the upgrade to the new firmware last night. It is now 11:00AM and it still thinks it is updating the new firmware. If I login to the dashboard. I get a message box saying that the firmware is being updated done unplug the device. If I ssh to the device it still is on version 308 the upgrade processes show up in a ps -eax command.

What is the proper method to get the upgrade to complete?


Still unable to upgrade to version 112. After the device hung this morning. I rebooted the device and tried to do an upgrade now. That also hung for ever. So I rebooted again and tried to upgrade using upgrade from file. It said importing. Then hung on the downloading screen at 0%. After an hour I rebooted the device.

Any Ideas?

After several attempts at trying to upgrade to firmware version. I had to delete /tmp/fw* files that were created during the upgrade process. So that I could retry the upgrade. With these files present the script would fail. I found that the script was failing on a process called It was trying to unmount USB devices and was hung on a lock.
When I killed the process and the upgrade continued and completed.



Thanks for coming back with the solution to your issue.

Hope this helps others users experiencing the same.