New folder content not displayed

Hi everyone! i am using a WDTV live with a WD MyBookLive 4TB, and i have encountered several problems…

one of them is, that if i copy new files to the MBL, they are not visible on the WDTV. Firmware up to date.

What i tried was:

-Restarting WDTV(power switch on remote): Still the same

-Reconnecting WDTV to network: Still the same

-Restarting MBL: Still the same

-unplugging WDTV + restarting WDTV: Works, new files are displayed.

But this is quite annoying, i dont want to walk to the WDTV and restart it everytime i copy new files onto the MBL… Any suggestions?

You could be using the media server option as oppose to the network share to access the files

the media server might not reflect the new files until compiled on the library

the network shares will display them right away

hmm, i hope i understood your answer correctly(no native English speaker :smiley:) - But i think i already did that.

Correct me please if i am wrong, but on the MBL there are 3 default shares: Public music, pictures and videos. I copied the new media files into these folders(shares) and it did not work until i unplugged and replugged the device.

I couldnt access the files either in the “files” menu nor in the “music” menu (for music) or in the "video menu (for video). 

It was possible to access the files from another PC and from a Mac, but not from the WDTV live