New Firmware Disconnecting My Cloud 3tb

I upgraded the firmware to the latest version at the start of January - then the device was bricked - couldn’t restore. It had worked fine for the last 18-24 months.

So bought a new 3tb my cloud last week which now disconnects all the time. I can’t access locally or outside the network. The fix is to reboot it. I have tried static IP, which works a bit better, but it still disconnects every 4-8 hours. On latest firmware and nothing else on my network has changed.

Hope someone has an idea what could be wrong and knows of a fix - thanks!

Hi there,

The fixed IP you have on your unit was setup on the router or the actual My Cloud device? You can also try to do a system only restore on the device see if that helps. Here is a link that might help you on this process:

When you say it disconnects, what are the LED’s on the My Cloud doing front and back when it disconnects. How about your router, what does the LED’s on it show for the My Cloud. What type of router do you have and is it 802.11n or 802.11ac?

As for outside your network who is your ISP?

The more up to date and modern all the equipment on your network the better it will work.

cat0w
USA

Check the /var/log/daemon.log to see if the eth0 is generating up and down log entires.

RAC

The blue light at the front stays on and the router lights are fine. The router is only 12 months old.

I have fixed the IP address through the WD dashboard outside of the DHCP range and turned off the sleep mode.

I am still getting the same issue.

The blue light is always on because you turned off sleep. You still need to look into the /var/log/daemon.log. You can use this command.
“cd /”
“grep eth0 /var/log/daemon.log”

If you device is disconnecting because of the network going down you will see a lot of up and down messages.

RAC

The command line is new to me - so have set tonight aside to do this.

We have Netflix and other networked devices working away at the same time with no issue when the My Cloud disconnects.

Do you know how to ssh into the My Cloud? You will have to download putty. The link below is where to get the putty for a windows system. Wen you open putty it will allow you to enter the ip address in the bar click on ssh button and then open. You should get a window opened with a prompt to login. Just enter root. Then it will ask for password. If you haven’t changed the default password then enter welc0me. Then just enter the commands without the quotes.

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

RAC