New firmware 2.02.32 (08/2014) not playing YOU TUBE

Dears, after install new firmware the YOU TUBE stopped to work.

When I enter in YOU TUBE the WD TV restart sunddely.

Does someone has a solution for it?


Hi  TiagoFontes,

If you reset the unit manually using the 4 seconds reset, do you get the same error?

Please see the following link for more detailes on how to reset the unit.

I am having the same problem. Opening YouTube Leanback reboots the system. I’m unable to use the app.

No amount of manual resetting solves it.

Never used the YouTube app before decided to just try it, rebooted my device too on first time ever use…

which ine are you talking about? one with red icon or black icon (leanback)?

red is working for me, tested it yesterday, paired with my account and videos are playing just fine

red, tried it again, reboot. I dont have a youtube account so no login

Black & White (You Tube Videos) - played ok / Red & White (You Tube) - played video then re-booted

Dear, i’ve tried both procedures and it didn’t work.

Is there any other solution?



Dear, I have exactly the same prob. First it was playing quite ok but after maybe 1 hour it always reboots and jump into a loop when I try to start youtube!

Any ideas? I will try to reboot it as described above.



Same thing here, after the update youtube leanback (red icon) does not work, as soon as it’s launched the wd will reboot. 

youtube (one with red icon) also crash and causes reboot intermittently.  This did not happen with the firmware before this one.    Also when it does work, sometimes i don’t get sound.  I can’t figure it out but the sound problem happend on both firmwares.

Guys, is the youtube issue resolved now ?

I have been using the newest firmware for my WD TV Live. Long time ago It can read the subtitle file and the youtube app run flawless, but now whenever I try the youtube app, it corrupts and restart the device. A new firmware should be released

If someone could give this a try and see if it works.  I came from the last version of 1.x (1.16.13) firmware and went directly to the latest.  My youtube app works just fine on my wd tv live streaming box.  Ive watched like 30 videos since the update a few weeks ago and havent had any issues with it yet.  Maybe if someone could flash back to 1.16.13 and then take the update and verify if that helps with the app reboots?