New Drive... DOESNT work! HALP!

So 3 days ago now, I bought a new 3TB personal cloud.  I go home, hook it up to a month old router/modem combo (motorola SBG6782-AC). Install the stuff on my computer and start transferring files using drag and drop with finder/file explorer.  It tells me 100GB will take 3 days.  So I let it sit.  The next morning, the file transfer errored out.  So I tried again, and even used a different computer.  Cant move my files!!!

In troubleshooting I noticed…

So I look into networking settings and I see this!


Thinking that something is wrong with my router I double checked my settings.

I tried a “factory” reset (which took all of last night) and it “STILL” doesn’t work!  Soo Frustrating!  Any Ideas of what to try next?  I could have just set up an external hard drive to my desktop as a network share easier than this! (My desktop runs all the time anyway, but was hoping to use this drive to serve my files instead).


The Cloud Access settings are irrelevent on a local network.   Come back to that issue when you start using the remote connectivity options.

It sounds like you’re using a Mac?   Did you enable AFP on the My Cloud, and are you connecting to the Cloud via AFP?

You have two different problems. The remote access message has nothing to do with the transferring of files problem. If you notice it says connected but just recommends that for best performance you should establish a direct connection.

I assume that you are transferring these files over a local network so a remote connection does not come into it.

Have you tried transferring a small amount of files at a time and does that work.